summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEugeniy Meshcheryakov <eugen@debian.org>2009-05-06 17:57:21 +0200
committerEugeniy Meshcheryakov <eugen@debian.org>2009-05-06 17:57:21 +0200
commit308525e34dd61319747ee60b4fa4cba723aeacd5 (patch)
tree5ccd45111ad5855d23b0457f98080465b03f7c46 /configure.ac
parentccf8bc85c08ba5602288caeb5062b3bf049a6960 (diff)
downloadsystemtap-steved-308525e34dd61319747ee60b4fa4cba723aeacd5.tar.gz
systemtap-steved-308525e34dd61319747ee60b4fa4cba723aeacd5.tar.xz
systemtap-steved-308525e34dd61319747ee60b4fa4cba723aeacd5.zip
Revert "Remove latex2html detection, it is not used anymore"
This reverts commit 3f6d0896b990c586667d0de08ac85b18effb0274.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ab315c10..e8a8efda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,7 +164,8 @@ AC_ARG_ENABLE([docs],
AC_CHECK_PROG(have_latex, latex, yes, no)
AC_CHECK_PROG(have_dvips, dvips, yes, no)
AC_CHECK_PROG(have_ps2pdf, ps2pdf, yes, no)
-if test "x${have_latex}${have_dvips}${have_ps2pdf}" != "xyesyesyes"; then
+AC_CHECK_PROG(have_latex2html, latex2html, yes, no)
+if test "x${have_latex}${have_dvips}${have_ps2pdf}${have_latex2html}" != "xyesyesyesyes"; then
if test "$enable_docs" == "yes"; then
AC_MSG_ERROR([cannot find all tools for building documentation])
fi
@@ -172,7 +173,7 @@ if test "x${have_latex}${have_dvips}${have_ps2pdf}" != "xyesyesyes"; then
AC_MSG_WARN([will not build documentation, cannot find all tools])
fi
fi
-if test "x${have_latex}${have_dvips}${have_ps2pdf}" == "xyesyesyes" -a "$enable_docs" != "no"; then
+if test "x${have_latex}${have_dvips}${have_ps2pdf}${have_latex2html}" == "xyesyesyesyes" -a "$enable_docs" != "no"; then
building_docs="yes"
fi
AM_CONDITIONAL([BUILD_DOCS], [test "$building_docs" == "yes"])