summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrank Ch. Eigler <fche@elastic.org>2010-03-08 16:22:42 -0500
committerFrank Ch. Eigler <fche@elastic.org>2010-03-08 16:22:42 -0500
commit12c1a00781ad7273546a9d16f4711876f328ab8c (patch)
tree588c89d0e601cc7bc1df4dd5497d1840ad4e73e0 /configure.ac
parent15f1dd6f3a95d9db007192730903a85b875d172f (diff)
downloadsystemtap-steved-12c1a00781ad7273546a9d16f4711876f328ab8c.tar.gz
systemtap-steved-12c1a00781ad7273546a9d16f4711876f328ab8c.tar.xz
systemtap-steved-12c1a00781ad7273546a9d16f4711876f328ab8c.zip
build: re-enable librpm checking
* configure.ac: With AC_CHECK_LIB()'s four-parameter variant, the default AC_DEFINE etc. is removed, so restore the key parts by hand.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index b37429d8..46719599 100644
--- a/configure.ac
+++ b/configure.ac
@@ -377,7 +377,10 @@ AC_ARG_WITH([rpm],
[AS_HELP_STRING([--with-rpm],
[query rpm database for missing debuginfos])], [], [with_rpm="auto"])
if test "$with_rpm" != "no"; then
- AC_CHECK_LIB(rpm, rpmtsInitIterator, have_librpm="yes", have_librpm="no")
+ AC_CHECK_LIB(rpm, rpmtsInitIterator, [
+ AC_DEFINE([HAVE_LIBRPM],[1],[have librpm])
+ stap_LIBS="$stap_LIBS -lrpm"
+ have_librpm="yes"], [have_librpm="no"])
if test "x$have_librpm" != "xyes" -a "$with_rpm" == "yes"; then
AC_MSG_ERROR([cannot find librpm])
fi
@@ -410,11 +413,11 @@ if test $enable_translator = yes; then
AC_CHECK_LIB(dw, dwarf_getelf,[],[
AC_MSG_ERROR([elfutils, libdw too old, need 0.126+])],
[-Wl,--start-group -ldw -lebl -Wl,--end-group -lelf])
- stap_LIBS="-Wl,--start-group -ldw -lebl -Wl,--end-group -lelf"
+ stap_LIBS="$stap_LIBS -Wl,--start-group -ldw -lebl -Wl,--end-group -lelf"
LIBS="$save_LIBS"
else
# We built our own and stap_LDFLAGS points at the install.
- stap_LIBS="-Wl,--start-group -ldw -lebl -Wl,--end-group -lelf"
+ stap_LIBS="$stap_LIBS -Wl,--start-group -ldw -lebl -Wl,--end-group -lelf"
fi
fi