summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2009-05-08 11:42:24 +0200
committerMark Wielaard <mjw@redhat.com>2009-05-08 11:42:24 +0200
commit07f8225311f85de5754bb594bf6ee945425dafcc (patch)
treea2f7d7daedc033e9a32b0a4fb08a29949016741d /configure.ac
parent532a25e60429f12cb92ef1056f1454815d135322 (diff)
downloadsystemtap-steved-07f8225311f85de5754bb594bf6ee945425dafcc.tar.gz
systemtap-steved-07f8225311f85de5754bb594bf6ee945425dafcc.tar.xz
systemtap-steved-07f8225311f85de5754bb594bf6ee945425dafcc.zip
Check whether certutil as provided by nss-tools is installed.
* configure.ac: Add check for certuril, don't build nss stap server when not found. * Makefile.in: Regenerated. * aclocal.m4: Likewise. * configure: Likewise. * doc/Makefile.in: Likewise. * doc/SystemTap_Tapset_Reference/Makefile.in: Likewise. * grapher/Makefile.in: Likewise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e8a8efda..f3135287 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,7 +228,8 @@ AC_ARG_ENABLE([server],
[enable building of stap-server/client (default on if nss etc. found).]),
[enable_server=$enableval],
[enable_server="check"])
-dnl Find the location of nss and nspr headers
+dnl Find the location of nss and nspr headers and certutil
+AC_CHECK_PROG(have_certutil, certutil, [yes], [no])
AC_CHECK_FILE([/usr/include/nss3], nssdir=nss3, [
AC_CHECK_FILE([/usr/include/nss], nssdir=nss)
])
@@ -249,18 +250,18 @@ AC_CHECK_LIB(nspr4, PR_Connect, [
AC_CHECK_LIB(ssl3, SSL_ReHandshake, have_nss_libs=yes)
])
fi
-if test "x${have_nss_includes}${have_nss_libs}" != "xyesyes"; then
+if test "x${have_nss_includes}${have_nss_libs}${have_certutil}" != "xyesyesyes"; then
if test "$enable_server" == "yes"; then
- AC_MSG_ERROR([cannot find all libraries for stap-server])
+ AC_MSG_ERROR([cannot find all libraries or tools for stap-server])
fi
if test "$enable_server" == "check"; then
- AC_MSG_WARN([will not build stap-server, cannot find all libraries])
+ AC_MSG_WARN([will not build stap-server, cannot find all libraries or tools])
fi
else
AC_DEFINE([HAVE_NSS], [1], [Define to 1 if you have the nss libraries.])
fi
-AM_CONDITIONAL([BUILD_SERVER], [test "x${have_nss_includes}${have_nss_libs}" == "xyesyes" -a "$enable_server" != "no"])
-AM_CONDITIONAL([HAVE_NSS], [test "x${have_nss_includes}${have_nss_libs}" == "xyesyes"])
+AM_CONDITIONAL([BUILD_SERVER], [test "x${have_nss_includes}${have_nss_libs}${javer_certutil}" == "xyesyesyes" -a "$enable_server" != "no"])
+AM_CONDITIONAL([HAVE_NSS], [test "x${have_nss_includes}${have_nss_libs}${have_certutil}" == "xyesyesyes"])
dnl Handle the optional grapher
AC_ARG_ENABLE([grapher],