summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2009-07-25 11:42:54 +0200
committerMark Wielaard <mjw@redhat.com>2009-07-25 11:49:56 +0200
commite38517841d86cfcbdeab66d5921fbcc3cbc92a10 (patch)
tree8007d01579f8d6b246502aa33c035b912decda7d /Makefile.am
parent92dad52bd5d51d32fc171620736bdc0ba9b890c4 (diff)
downloadsystemtap-steved-e38517841d86cfcbdeab66d5921fbcc3cbc92a10.tar.gz
systemtap-steved-e38517841d86cfcbdeab66d5921fbcc3cbc92a10.tar.xz
systemtap-steved-e38517841d86cfcbdeab66d5921fbcc3cbc92a10.zip
Explicitly link with nss3 nspr4 and plc4 when used.
GNU gold depends on all libraries providing symbols being explicitly linked in (PR 10238). And it is pedantically more correct indeed. * Makefile.am (stap_LD_ADD): Add -lnspr4 when HAVE_NSS. (staprun_LDADD): Likewise. (stap_client_connect_LDADD): Add -lnss3 -lnspr4 -lplc4 when BUILD_SERVER. (stap_server_connect_LDADD): Likewise. * Makefile.in: Regenerated. * aclocal.m4: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ad70f9f4..37491eef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,7 +99,7 @@ stap_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
if HAVE_NSS
stap_SOURCES += modsign.cxx nsscommon.c
stap_CPPFLAGS += $(nss_CFLAGS) $(nspr_CFLAGS)
-stap_LDADD += -lnss3
+stap_LDADD += -lnss3 -lnspr4
stap_client_connect_LDFLAGS = $(AM_LDFLAGS)
stap_server_connect_LDFLAGS = $(AM_LDFLAGS)
@@ -154,7 +154,7 @@ staprun_LDADD = @PROCFLAGS@
if HAVE_NSS
staprun_SOURCES += runtime/staprun/modverify.c nsscommon.c
staprun_CFLAGS += $(nss_CFLAGS) $(nspr_CFLAGS)
-staprun_LDADD += -lnss3
+staprun_LDADD += -lnss3 -lnspr4
endif
stapio_SOURCES = runtime/staprun/stapio.c \
@@ -180,11 +180,11 @@ if BUILD_TRANSLATOR
if BUILD_SERVER
stap_client_connect_SOURCES = stap-client-connect.c
stap_client_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
-stap_client_connect_LDADD = -lssl3
+stap_client_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
stap_server_connect_SOURCES = stap-server-connect.c
stap_server_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
-stap_server_connect_LDADD = -lssl3
+stap_server_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
endif
noinst_PROGRAMS = loc2c-test