summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Brolley <brolley@redhat.com>2009-09-14 15:06:36 -0400
committerDave Brolley <brolley@redhat.com>2009-09-14 15:06:36 -0400
commitb9c1510ee2ef5283d7faafad4e82a4bb933d9e29 (patch)
tree995b7887f23f8d1e6f3a35f6701af7afd223aebd /Makefile.am
parent1393520fe0a1064665938bcea0d6382610a478b0 (diff)
downloadsystemtap-steved-b9c1510ee2ef5283d7faafad4e82a4bb933d9e29.tar.gz
systemtap-steved-b9c1510ee2ef5283d7faafad4e82a4bb933d9e29.tar.xz
systemtap-steved-b9c1510ee2ef5283d7faafad4e82a4bb933d9e29.zip
2009-09-14 Dave Brolley <brolley@redhat.com>
* modsign.cxx (init_cert_db_path): Use 'system' call. (sign_module): Renamed to 'main'. This is now an independant program. Check for arguments. Return 1 on error. * buildrun.cxx (modsign.h): Don't #include it. (compile_pass): Don't sign the module. * main.cxx (main): Don't copy the module signature. * cache.cxx (add_to_cache): Don't cache the module signature. * Makefile.am (bin_PROGRAMS): Add stap-sign-module. (stap_SOURCES): Remove modsign.cxx and nsscommon.c. (stap_sign_module_SOURCES): New variable. (stap_sign_module_CPPFLAGS): New variable. (stap_sign_module_LDFLAGS): New variable. (stap_sign_module_LDADD): New variable. * stap-server (initialization): Initialize unprivileged. (parse_options): Handle --unprivileged. (create_response): Call stap-sign-module if --unprivileged was specified. * systemtap.spec: Add stap-sign-module to stap-server. * Makefile.in: Regenerated. * doc/Makefile.in: Regenerated. * doc/SystemTap_Tapset_Reference/Makefile.in: Regenerated. * grapher/Makefile.in: Regenerated. * testsuite/Makefile.in: Regenerated. * aclocal.m4: Likewise. * testsuite/aclocal.m4: Likewise. * configure: Likewise. * testsuite/configure: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index c2234d1c..a4a828a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ bin_SCRIPTS += dtrace
if BUILD_SERVER
man_MANS += stap-server.8
-bin_PROGRAMS += stap-client-connect stap-server-connect
+bin_PROGRAMS += stap-client-connect stap-server-connect stap-sign-module
bin_SCRIPTS += stap-client stap-serverd stap-server stap-find-servers \
stap-start-server stap-find-or-start-server stap-stop-server \
stap-authorize-server-cert
@@ -97,12 +97,9 @@ stap_CPPFLAGS = $(AM_CPPFLAGS)
stap_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
if HAVE_NSS
-stap_SOURCES += modsign.cxx nsscommon.c
-stap_CPPFLAGS += $(nss_CFLAGS) $(nspr_CFLAGS)
-stap_LDADD += -lnss3 -lnspr4
-
stap_client_connect_LDFLAGS = $(AM_LDFLAGS)
stap_server_connect_LDFLAGS = $(AM_LDFLAGS)
+stap_sign_module_LDFLAGS = $(AM_LDFLAGS)
endif
if BUILD_ELFUTILS
@@ -185,6 +182,11 @@ stap_client_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
stap_server_connect_SOURCES = stap-server-connect.c
stap_server_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_server_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
+
+stap_sign_module_SOURCES = modsign.cxx nsscommon.c
+stap_sign_module_CPPFLAGS = -Wall -Werror $(AM_CPPFLAGS) $(nss_CFLAGS) $(nspr_CFLAGS)
+
+stap_sign_module_LDADD = -lnss3 -lnspr4
endif
noinst_PROGRAMS = loc2c-test