summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Brolley <brolley@redhat.com>2009-11-05 14:52:56 -0500
committerDave Brolley <brolley@redhat.com>2009-11-05 14:52:56 -0500
commita0fc7f8e96d3818a963ad41aa5043d2a5bbcb9e5 (patch)
tree37ef7bd65bf563fb88d0cb5ef34227fed324ef31 /Makefile.am
parent5807ac6473b47074cd90f93f5b1b3c3eb452fed9 (diff)
downloadsystemtap-steved-a0fc7f8e96d3818a963ad41aa5043d2a5bbcb9e5.tar.gz
systemtap-steved-a0fc7f8e96d3818a963ad41aa5043d2a5bbcb9e5.tar.xz
systemtap-steved-a0fc7f8e96d3818a963ad41aa5043d2a5bbcb9e5.zip
PR 9973: Sign uprobes.ko when it is created and load it using insert_module.
Create home directory manually for stap-server.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 24 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index ede3c303..f53e4d07 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ man/stapprobes.tcp.3stap man/stapprobes.udp.3stap
# see also configure.ac
bin_PROGRAMS = staprun
-bin_SCRIPTS = stap-report stap-env stap-gen-cert stap-authorize-cert stap-authorize-signing-cert
+bin_SCRIPTS = stap-report
oldinclude_HEADERS = includes/sys/sdt.h
if BUILD_TRANSLATOR
@@ -31,13 +31,18 @@ bin_PROGRAMS += stap
man_MANS += stap.1
bin_SCRIPTS += dtrace
+if HAVE_NSS
+bin_PROGRAMS += stap-sign-module
+bin_SCRIPTS += stap-env stap-gen-cert stap-authorize-cert stap-authorize-signing-cert
+
if BUILD_SERVER
man_MANS += stap-server.8
-bin_PROGRAMS += stap-client-connect stap-server-connect stap-sign-module
+bin_PROGRAMS += stap-client-connect stap-server-connect
bin_SCRIPTS += stap-client stap-serverd stap-server stap-find-servers \
stap-start-server stap-find-or-start-server stap-stop-server \
stap-authorize-server-cert
endif
+endif
stap_SOURCES = main.cxx \
parse.cxx staptree.cxx elaborate.cxx translate.cxx \
@@ -101,6 +106,17 @@ if HAVE_NSS
stap_client_connect_LDFLAGS = $(AM_LDFLAGS)
stap_server_connect_LDFLAGS = $(AM_LDFLAGS)
stap_sign_module_LDFLAGS = $(AM_LDFLAGS)
+
+if BUILD_SERVER
+install-exec-local: install-scripts
+
+PHONIES += install-scripts
+# scripts must be installed before this rule is run
+install-scripts: install-binSCRIPTS
+ for f in $(bin_SCRIPTS); do \
+ sed -i -e "/INSTALL-HOOK/d;s,exec_prefix=.*,exec_prefix=$(exec_prefix)/bin/,;s,sysconfdir=.*,sysconfdir=$(sysconfdir)," $(DESTDIR)$(bindir)/$$f; \
+ done
+endif
endif
if BUILD_ELFUTILS
@@ -129,16 +145,6 @@ install-elfutils:
install-exec-local: install-elfutils
endif
-if BUILD_SERVER
-install-exec-local: install-scripts
-
-PHONIES += install-scripts
-# scripts should be installed before this rule is run
-install-scripts: install-binSCRIPTS
- for f in $(bin_SCRIPTS); do \
- sed -i -e "/INSTALL-HOOK/d;s,exec_prefix=.*,exec_prefix=$(exec_prefix)/bin/,;s,sysconfdir=.*,sysconfdir=$(sysconfdir)," $(DESTDIR)$(bindir)/$$f; \
- done
-endif
endif
staprun_SOURCES = runtime/staprun/staprun.c runtime/staprun/staprun_funcs.c\
@@ -175,6 +181,11 @@ pkglibexec_PROGRAMS = stapio
CLEANFILES += $(pkglibexec_PROGRAMS)
if BUILD_TRANSLATOR
+if HAVE_NSS
+stap_sign_module_SOURCES = modsign.cxx nsscommon.c
+stap_sign_module_CPPFLAGS = -Wall -Werror $(AM_CPPFLAGS) $(nss_CFLAGS) $(nspr_CFLAGS)
+stap_sign_module_LDADD = -lnss3 -lnspr4
+
if BUILD_SERVER
stap_client_connect_SOURCES = stap-client-connect.c nsscommon.c
stap_client_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
@@ -183,11 +194,7 @@ stap_client_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
stap_server_connect_SOURCES = stap-server-connect.c nsscommon.c
stap_server_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_server_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
-
-stap_sign_module_SOURCES = modsign.cxx nsscommon.c
-stap_sign_module_CPPFLAGS = -Wall -Werror $(AM_CPPFLAGS) $(nss_CFLAGS) $(nspr_CFLAGS)
-
-stap_sign_module_LDADD = -lnss3 -lnspr4
+endif
endif
noinst_PROGRAMS = loc2c-test