summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrank Ch. Eigler <fche@elastic.org>2009-10-14 17:02:47 -0400
committerFrank Ch. Eigler <fche@elastic.org>2009-10-14 17:05:40 -0400
commit739cf6877b9bd84b0aba47f5c4c205a9dd63a93d (patch)
tree4e8f02f3a1a668084ef6f6202826d85016369c22 /Makefile.am
parent85dfc5c81e213a1fc67c8c50d0e1101659c61d6e (diff)
downloadsystemtap-steved-739cf6877b9bd84b0aba47f5c4c205a9dd63a93d.tar.gz
systemtap-steved-739cf6877b9bd84b0aba47f5c4c205a9dd63a93d.tar.xz
systemtap-steved-739cf6877b9bd84b0aba47f5c4c205a9dd63a93d.zip
PR10331: improve nss error message handling
* stapsslerr.h: New file containing NSS* error number to string mappings. Originally from mozilla NSS documentation, also seen in other GPLv2 software. * nsscommon.c (nssError): Print error number, and text from <stapsslerr.h>. * stap-{client,server}-connect.c (errWarn): Standardize on nssError(). * Makefile.am (nss binaries): Also link in nsscommon.c.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index aa45bf0f..ede3c303 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -176,11 +176,11 @@ CLEANFILES += $(pkglibexec_PROGRAMS)
if BUILD_TRANSLATOR
if BUILD_SERVER
-stap_client_connect_SOURCES = stap-client-connect.c
+stap_client_connect_SOURCES = stap-client-connect.c nsscommon.c
stap_client_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_client_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4
-stap_server_connect_SOURCES = stap-server-connect.c
+stap_server_connect_SOURCES = stap-server-connect.c nsscommon.c
stap_server_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_server_connect_LDADD = -lssl3 -lnss3 -lnspr4 -lplc4