summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorCharley Wang <chwang@redhat.com>2009-11-30 13:31:10 -0500
committerCharley Wang <chwang@redhat.com>2009-11-30 13:31:10 -0500
commit6ca3a0049cb5ce1a42b5ee38925d9d25c3d8b28d (patch)
tree8055226c34c9e0b1a89c1a57cf2f2234dc38fd37 /Makefile.am
parent1302a542db385c63ec1702dff9495870edf5b095 (diff)
downloadsystemtap-steved-6ca3a0049cb5ce1a42b5ee38925d9d25c3d8b28d.tar.gz
systemtap-steved-6ca3a0049cb5ce1a42b5ee38925d9d25c3d8b28d.tar.xz
systemtap-steved-6ca3a0049cb5ce1a42b5ee38925d9d25c3d8b28d.zip
PR10901: Add -D_FILE_OFFSET_BITS=64 to Makefile.am for stap and staprun
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 469601c3..bc1d41f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,7 +97,7 @@ cscope:
PHONIES =
if BUILD_TRANSLATOR
-stap_CFLAGS = $(AM_CFLAGS) @PIECFLAGS@
+stap_CFLAGS = $(AM_CFLAGS) @PIECFLAGS@ -D_FILE_OFFSET_BITS=64
stap_CXXFLAGS = $(AM_CXXFLAGS) @PIECXXFLAGS@
stap_CPPFLAGS = $(AM_CPPFLAGS)
stap_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
@@ -151,7 +151,7 @@ staprun_SOURCES = runtime/staprun/staprun.c runtime/staprun/staprun_funcs.c\
runtime/staprun/ctl.c runtime/staprun/common.c
staprun_CPPFLAGS = $(AM_CPPFLAGS)
-staprun_CFLAGS = $(AM_CFLAGS) @PIECFLAGS@ -DSINGLE_THREADED -fno-strict-aliasing -fno-builtin-strftime
+staprun_CFLAGS = $(AM_CFLAGS) @PIECFLAGS@ -DSINGLE_THREADED -fno-strict-aliasing -fno-builtin-strftime -D_FILE_OFFSET_BITS=64
staprun_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
staprun_LDADD =