summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorWilliam Cohen <wcohen@redhat.com>2009-05-27 11:14:12 -0400
committerWilliam Cohen <wcohen@redhat.com>2009-05-27 11:14:12 -0400
commit2ed04863c3426f94932d4a4e4b5d6c7b84e49dfd (patch)
treef3eccb813b7496111613614552198bdaf4223deb /Makefile.am
parenteee30f40ac28c7090a269611fb1baea5c050c612 (diff)
downloadsystemtap-steved-2ed04863c3426f94932d4a4e4b5d6c7b84e49dfd.tar.gz
systemtap-steved-2ed04863c3426f94932d4a4e4b5d6c7b84e49dfd.tar.xz
systemtap-steved-2ed04863c3426f94932d4a4e4b5d6c7b84e49dfd.zip
Suggest rpms to install using debuginfo-install.
The patch makes use of the RPM libraries to determine which rpm supplied the executable and from that information suggest a command to install the appropriate debuginfo rpm. This is enabled using the "--with-rpm" option for configure. Can be explicitly disabled with "--without-rpm".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 77681c83..f11c24c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,8 +40,8 @@ stap_SOURCES = main.cxx \
cache.cxx util.cxx coveragedb.cxx dwarf_wrappers.cxx \
tapset-been.cxx tapset-procfs.cxx tapset-timers.cxx \
tapset-perfmon.cxx tapset-mark.cxx tapset-itrace.cxx \
- tapset-utrace.cxx task_finder.cxx dwflpp.cxx
-stap_LDADD = @stap_LIBS@ @sqlite3_LIBS@
+ tapset-utrace.cxx task_finder.cxx dwflpp.cxx rpm_finder.cxx
+stap_LDADD = @stap_LIBS@ @sqlite3_LIBS@ @rpm_LIBS@
BUILT_SOURCES =
CLEANFILES =