summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTim Moore <timoore@redhat.com>2009-04-15 18:43:23 +0200
committerTim Moore <timoore@redhat.com>2009-04-15 19:00:00 +0200
commit2d45e339f3287cf0b4805ea91b3aa9f17b6d4752 (patch)
treeabd4c3faf3c774702b85a0ff6fb50da184fd5023 /Makefile.am
parent7a51212ca1895b85f400fafe0e5198525996af1d (diff)
downloadsystemtap-steved-2d45e339f3287cf0b4805ea91b3aa9f17b6d4752.tar.gz
systemtap-steved-2d45e339f3287cf0b4805ea91b3aa9f17b6d4752.tar.xz
systemtap-steved-2d45e339f3287cf0b4805ea91b3aa9f17b6d4752.zip
graphing widget and test harness
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f5fedae1..26a4760e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,7 @@ man/stapprobes.signal.3stap man/stapprobes.socket.3stap \
man/stapprobes.tcp.3stap man/stapprobes.udp.3stap
# see also configure.ac
-bin_PROGRAMS = stap staprun
+bin_PROGRAMS = stap staprun grapher
bin_SCRIPTS = stap-report
oldinclude_HEADERS = includes/sys/sdt.h
if BUILD_SERVER
@@ -86,6 +86,10 @@ stap_CXXFLAGS = $(AM_CXXFLAGS) @PIECXXFLAGS@
stap_CPPFLAGS = $(AM_CPPFLAGS)
stap_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
+grapher_CXXFLAGS = $(GRAPHER_CFLAGS)
+grapher_SOURCES = grapher.cxx GraphWidget.cxx CairoWidget.cxx
+grapher_LDADD = $(GRAPHER_LIBS)
+
if BUILD_SERVER
stap_client_connect_LDFLAGS = $(AM_LDFLAGS)
stap_server_connect_LDFLAGS = $(AM_LDFLAGS)