summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Brolley <brolley@redhat.com>2009-11-25 14:14:03 -0500
committerDave Brolley <brolley@redhat.com>2009-11-25 14:14:03 -0500
commit0da3e7a0e77120670cb69c55ad5418f2bf2afb9d (patch)
tree3ef463df086114aeb42630db819ff9d048712b97 /Makefile.am
parentff3576d585aee3140b41bb77a0e8e4063e704f43 (diff)
downloadsystemtap-steved-0da3e7a0e77120670cb69c55ad5418f2bf2afb9d.tar.gz
systemtap-steved-0da3e7a0e77120670cb69c55ad5418f2bf2afb9d.tar.xz
systemtap-steved-0da3e7a0e77120670cb69c55ad5418f2bf2afb9d.zip
- Allow root, the owner of the uprobes build directory and the members of the
group owner of the uprobes buld directory to build uprobes.ko. - When building uprobes.ko, make all generated files writable by the group owner of the uprobes build directory. - Don't change the group owner of the uprobes build directory during 'make install'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 7d084324..469601c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -242,10 +242,6 @@ install-data-local:
do $(INSTALL_DATA) -D $$f $(DESTDIR)$(pkgdatadir)/runtime/transport/$$f; done)
(cd $(srcdir)/runtime/uprobes; for f in Makefile *.[ch]; \
do $(INSTALL_DATA) -D $$f $(DESTDIR)$(pkgdatadir)/runtime/uprobes/$$f; done)
- if getent group stap-server >/dev/null; then \
- chgrp stap-server $(DESTDIR)$(pkgdatadir)/runtime/uprobes && \
- chmod 775 $(DESTDIR)$(pkgdatadir)/runtime/uprobes; \
- fi
(cd $(srcdir)/runtime/uprobes2; for f in *.[ch]; \
do $(INSTALL_DATA) -D $$f $(DESTDIR)$(pkgdatadir)/runtime/uprobes2/$$f; done)
(cd $(srcdir)/tapset; find . \( -name '*.stp' -o -name README \) -print \