summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorhunt <hunt>2007-06-20 21:35:03 +0000
committerhunt <hunt>2007-06-20 21:35:03 +0000
commit0bcb278dec439c699485c7fab8bd1174550788d9 (patch)
tree84cd8d455eee39d8b9b12d8cc1e2129df45d5382 /Makefile.am
parent8ae7a94ac6bfbee8f6ee4ba38151de9c3aed5859 (diff)
downloadsystemtap-steved-0bcb278dec439c699485c7fab8bd1174550788d9.tar.gz
systemtap-steved-0bcb278dec439c699485c7fab8bd1174550788d9.tar.xz
systemtap-steved-0bcb278dec439c699485c7fab8bd1174550788d9.zip
2007-06-20 Martin Hunt <hunt@redhat.com>
* Makefile.am (noinst_PROGRAMS): Add stap_merge. * Makefile.in: Rebuilt: * config.in: Rebuilt
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 60066402..5c9a37d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,12 +61,15 @@ staprun_LDADD = @PROCFLAGS@ -lpthread
pkglibexec_SCRIPTS = stp_check
CLEANFILES += $(pkglibexec_SCRIPTS)
-noinst_PROGRAMS = loc2c-test
+noinst_PROGRAMS = loc2c-test stap_merge
loc2c_test_SOURCES = loc2c-test.c loc2c.c
loc2c_test_CPPFLAGS = $(stap_CPPFLAGS)
loc2c_test_LDFLAGS = $(stap_LDFLAGS)
loc2c_test_LDADD = $(stap_LDADD)
+stap_merge_SOURCES = runtime/staprun/stap_merge.c
+stap_merge_CFLAGS = @PROCFLAGS@ $(AM_CFLAGS)
+
# Get extra libs as needed
LDADD =