summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorEugeniy Meshcheryakov <eugen@debian.org>2009-04-06 17:42:18 +0200
committerEugeniy Meshcheryakov <eugen@debian.org>2009-04-06 17:42:18 +0200
commit009b315e209db7ab3569c54950afe31b6172b174 (patch)
tree9481b28cadccebeb60477c9a7fc6fb64fd93c873 /Makefile.am
parenta03c97419b5192fd594afb1f84e9ae4d0801e3a9 (diff)
downloadsystemtap-steved-009b315e209db7ab3569c54950afe31b6172b174.tar.gz
systemtap-steved-009b315e209db7ab3569c54950afe31b6172b174.tar.xz
systemtap-steved-009b315e209db7ab3569c54950afe31b6172b174.zip
Make install-scripts depend on install-binSCRIPTS
This is needed for running make with -j. Fixes Debian bug #522800.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 580c4178..b4d97e9a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,7 +122,8 @@ if BUILD_SERVER
install-exec-local: install-scripts
PHONIES += install-scripts
-install-scripts:
+# scripts should be installed before this rule is run
+install-scripts: install-binSCRIPTS
for f in $(bin_SCRIPTS); do \
sed -i -e "/INSTALL-HOOK/d;s,exec_prefix=,exec_prefix=$(exec_prefix)/bin/,;s,sysconfdir=.*,sysconfdir=$(sysconfdir)," $(DESTDIR)$(bindir)/$$f; \
done