summaryrefslogtreecommitdiffstats
path: root/tests/cunit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/cunit/Makefile.am')
-rw-r--r--tests/cunit/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/cunit/Makefile.am b/tests/cunit/Makefile.am
new file mode 100644
index 0000000..1e5c0e5
--- /dev/null
+++ b/tests/cunit/Makefile.am
@@ -0,0 +1,19 @@
+AM_CFLAGS = @CFLAGS@
+
+INCLUDES = \
+ $(OPENWSMAN_CFLAGS)
+
+
+wsman_cunit_tests_LDADD = \
+ $(OPENWSMAN_LIBS) -lcunit -lcurl
+
+
+wsman_cunit_tests_SOURCES = run_tests.c \
+ common.c \
+ common.h \
+ identify.c \
+ enumeration.c \
+ transfer_get.c
+
+noinst_PROGRAMS = wsman_cunit_tests
+