summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAnas Nashif <nashif@intel.com>2007-08-03 12:40:05 +0000
committerAnas Nashif <nashif@intel.com>2007-08-03 12:40:05 +0000
commitdc09b03a2a705364b054fcaf7c65afd7f6583a81 (patch)
treec0af8dc4f35ca83d100f17dde6dbd4be98b584fb /configure.in
parent0288eff339ef36e57c0bd86d274f7f8b02664d87 (diff)
downloadwsmancli-dc09b03a2a705364b054fcaf7c65afd7f6583a81.tar.gz
wsmancli-dc09b03a2a705364b054fcaf7c65afd7f6583a81.tar.xz
wsmancli-dc09b03a2a705364b054fcaf7c65afd7f6583a81.zip
treat warnings as errors and fixed them
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4ff99a3..c363d99 100644
--- a/configure.in
+++ b/configure.in
@@ -19,6 +19,20 @@ PKG_CHECK_MODULES(OPENWSMAN, [openwsman >= 0.5.0])
have_cunit=no
AC_CHECK_HEADERS([CUnit/Basic.h], have_cunit="yes" )
AM_CONDITIONAL(BUILD_CUNIT_TESTS, test "$have_cunit" == "yes")
+dnl *************************************
+dnl *** Warnings to show if using GCC ***
+dnl *************************************
+
+AC_ARG_ENABLE(more-warnings,
+ [ --disable-more-warnings Inhibit compiler warnings],
+ set_more_warnings=no)
+
+if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
+ CFLAGS="$CFLAGS \
+ -Wall -Wstrict-prototypes -Wmissing-declarations \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
+ -Wunused -Werror"
+fi
AC_OUTPUT([
wsmancli.spec