summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-01-17 12:56:31 -0500
committerMonty Taylor <mordred@inaugust.com>2013-01-18 16:49:50 -0500
commit9c8685a748714d9ff626694a4838d43edf33ef34 (patch)
tree166ecb98004a52bf9a796a58d00740b97b92231c /setup.py
parent5f5ef7deb22b86310aa128dcb71534f6fc9deb08 (diff)
downloadoslo-9c8685a748714d9ff626694a4838d43edf33ef34.tar.gz
oslo-9c8685a748714d9ff626694a4838d43edf33ef34.tar.xz
oslo-9c8685a748714d9ff626694a4838d43edf33ef34.zip
Use revno and git sha for pre-release versioning.
In discussions with ttx and zul, it became clear that the git describe info for our intra-release case wasn't providing any value and was providing confusion. Additionally, plain git sha's are not providing enough info. So, the scheme settled on that breaks the least amount of things and yet still reduces complexity is: if pre-version: # server projects try: use current tag except: use pre-version+revcount+gitsha else: use git describe | s/-/./ Additionally, we'll use a as a prefix for the revcount, b as the prefix for the milestone portion of a milestone tag, and rc as the prefix for rc's, so that for our releases, python version sorting works as expected. Change-Id: I6f0fe029d225afa8f435bc83216fc144c2402ae0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0a590a1..9262a09 100644
--- a/setup.py
+++ b/setup.py
@@ -42,7 +42,7 @@ weights = [
setuptools.setup(
name=package,
- version=setup.get_version(package),
+ version=setup.get_version(package, '2013.1'),
description="Common components for Openstack",
long_description="Common components for Openstack "
"including paster templates.",