summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-01-03 09:22:00 -0800
committerMonty Taylor <mordred@inaugust.com>2013-01-11 17:34:13 -0800
commit7ee9613600db879abff65da48e6e7293b4c4c659 (patch)
treee3a5109b0e079d5953d8d798f15f5b378a1cdcc7 /setup.py
parenta8973c524c9fe901972ba61f34dafac7438417c9 (diff)
downloadoslo-7ee9613600db879abff65da48e6e7293b4c4c659.tar.gz
oslo-7ee9613600db879abff65da48e6e7293b4c4c659.tar.xz
oslo-7ee9613600db879abff65da48e6e7293b4c4c659.zip
Simplify version processing.
In response to the cessation of per-commit tarballs produced by the CI systems, simplify the version processing code. We did many many many complicated things to support producing release artifacts that were not actually supported release artifacts. After a bunch of issues emerged, it was determined that the best way forward was to stop producing quasi-not-really non-release tarballs. If people want to consume versions of openstack that are not released versions, the git repos are always available. Additionally, this patch removes versioninfo and just uses PKG-INFO and pkg_resources to handle version processing. Change-Id: I5c799f3520adb2ba5288d852543706d81a92f8a1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 1a388ac..0a590a1 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
#!/usr/bin/python
# -*- encoding: utf-8 -*-
# Copyright (c) 2012 OpenStack, LLC.
+# Copyright (c) 2012-2013 Hewlett-Packard Development Company, L.P.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -21,6 +22,7 @@ from openstack.common import setup
requires = setup.parse_requirements()
depend_links = setup.parse_dependency_links()
+package = 'openstack.common'
filters = [
"AvailabilityZoneFilter = "
@@ -39,8 +41,8 @@ weights = [
]
setuptools.setup(
- name='openstack.common',
- version=setup.get_post_version('openstack'),
+ name=package,
+ version=setup.get_version(package),
description="Common components for Openstack",
long_description="Common components for Openstack "
"including paster templates.",
@@ -62,7 +64,6 @@ setuptools.setup(
zip_safe=True,
install_requires=requires,
dependency_links=depend_links,
- setup_requires=['setuptools-git>=0.4'],
entry_points={
"openstack.common.scheduler.filters": filters,
"openstack.common.tests.fakes.weights": weights,