summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-02-06 09:49:09 -0500
committerMonty Taylor <mordred@inaugust.com>2012-02-06 08:06:12 -0800
commit2ca2b4b49367d6033bdd2c5e47d17392e7aba318 (patch)
tree0242581d969706676e403e4d46636be051e28189 /setup.py
parentbf1d46353edba3f6a46edf2bc96fb9452efeb9aa (diff)
downloadoslo-2ca2b4b49367d6033bdd2c5e47d17392e7aba318.tar.gz
oslo-2ca2b4b49367d6033bdd2c5e47d17392e7aba318.tar.xz
oslo-2ca2b4b49367d6033bdd2c5e47d17392e7aba318.zip
Updated tox config for multi-python testing.
Change-Id: Ib1f768c6783db0e63cb51dfc767ae5a31a295c76
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 13 insertions, 14 deletions
diff --git a/setup.py b/setup.py
index 2c0c917..0f7e1c1 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,18 @@
from setuptools import setup, find_packages
+from openstack.common.setup import parse_requirements
+from openstack.common.setup import parse_dependency_links
+from openstack.common.setup import write_requirements
+
version = '0.1'
+requires = parse_requirements(['requirements.txt', 'tools/pip-requires'])
+
+depend_links = parse_dependency_links(['requirements.txt',
+ 'tools/pip-requires'])
+
+write_requirements()
+
setup(name='openstack.common',
version=version,
description="Common components for Openstack",
@@ -23,20 +34,8 @@ Common components for Openstack including paster templates.
packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
include_package_data=True,
zip_safe=True,
- install_requires=[
- 'greenlet>=0.3.1',
- 'pep8',
- 'pylint',
- 'eventlet',
- 'PasteDeploy',
- 'routes',
- 'webob',
- 'nose',
- 'nose-exclude',
- 'mock',
- 'webtest',
- 'lxml',
- ],
+ install_requires=requires,
+ dependency_links=depend_links,
entry_points="""
# -*- Entry points: -*-
""",