summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-04-03 11:20:33 -0400
committerMonty Taylor <mordred@inaugust.com>2013-04-07 02:32:37 -0400
commit0b15de18fba81acfcffc5861f34e0199caef8fb9 (patch)
tree1f7a1240b95645d2abd0a4c47adcafebe925b2d1 /setup.py
parent49153d44ca6620a5027b56036e4077725aa90faf (diff)
downloadoslo-0b15de18fba81acfcffc5861f34e0199caef8fb9.tar.gz
oslo-0b15de18fba81acfcffc5861f34e0199caef8fb9.tar.xz
oslo-0b15de18fba81acfcffc5861f34e0199caef8fb9.zip
Move bin/ scripts to entrypoints.
Instead of propogating more bin scripts, migrate these to be things that can be consumed as entrypoints. Change-Id: Ic01e0f16fe9e7634708fbb51499ccea3f4f40d63
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6ee6d00..83c56fb 100644
--- a/setup.py
+++ b/setup.py
@@ -67,6 +67,10 @@ setuptools.setup(
entry_points={
"openstack.common.scheduler.filters": filters,
"openstack.common.tests.fakes.weights": weights,
+ "console_scripts": [
+ 'oslo-rootwrap = openstack.common.rootwrap.cmd:main',
+ 'oslo-rpc-zmq-receiver = openstack.common.rpc.zmq_receiver:main',
+ ]
},
namespace_packages=['openstack'],
)