summaryrefslogtreecommitdiffstats
path: root/openstack/common/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-01-17 11:57:21 -0500
committerMonty Taylor <mordred@inaugust.com>2013-01-18 13:47:59 -0500
commit5f5ef7deb22b86310aa128dcb71534f6fc9deb08 (patch)
tree81ac2430e77d5387589185d12d9329356d114b8a /openstack/common/setup.py
parentb1c5269b20e58213da93254537435b67c258f236 (diff)
downloadoslo-5f5ef7deb22b86310aa128dcb71534f6fc9deb08.tar.gz
oslo-5f5ef7deb22b86310aa128dcb71534f6fc9deb08.tar.xz
oslo-5f5ef7deb22b86310aa128dcb71534f6fc9deb08.zip
Add env var version override for packagers.
Fixes bug 1100805. Change-Id: I8c8ba8610ed2d9093e188c1412e9689314560015
Diffstat (limited to 'openstack/common/setup.py')
-rw-r--r--openstack/common/setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/openstack/common/setup.py b/openstack/common/setup.py
index 7267a6a..c1db232 100644
--- a/openstack/common/setup.py
+++ b/openstack/common/setup.py
@@ -293,6 +293,9 @@ def get_version(package_name):
to make a source tarball from a fork of our repo with additional tags in it
that they understand and desire the results of doing that.
"""
+ version = os.environ.get("OSLO_PACKAGE_VERSION", None)
+ if version:
+ return version
version = get_version_from_pkg_info(package_name)
if version:
return version