summaryrefslogtreecommitdiffstats
path: root/utils/mount/Makefile.am
diff options
context:
space:
mode:
authorAmit Gud <agud@redhat.com>2006-06-12 19:06:36 -0400
committerNeil Brown <neilb@suse.de>2006-06-16 12:18:55 +1000
commita0520fa1a41bd33815b331b660b4545f2723495c (patch)
tree01c5f70db5da8039cc87c181e8c315d9f8c87026 /utils/mount/Makefile.am
parentb9559d9cd6255ec3068d1c840361ad972e2e066e (diff)
downloadnfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.tar.gz
nfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.tar.xz
nfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.zip
Move NFS mount code from util-linux to nfs-utils - part 1
Adds the mount directory and the code to mount and umount the NFS file system. Signed-off-by: Amit Gud <agud@redhat.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'utils/mount/Makefile.am')
-rw-r--r--utils/mount/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/utils/mount/Makefile.am b/utils/mount/Makefile.am
new file mode 100644
index 0000000..084a5db
--- /dev/null
+++ b/utils/mount/Makefile.am
@@ -0,0 +1,38 @@
+## Process this file with automake to produce Makefile.in
+
+man8_MANS = mount.nfs.man umount.nfs.man
+
+sbin_PROGRAMS = mount.nfs
+EXTRA_DIST = nfsmount.x $(man8_MANS)
+mount_nfs_SOURCES = mount.c nfsmount.c nfs4mount.c nfsumount.c \
+ nfsmount_xdr.c mount_constants.h nfs4_mount.h nfsmount.h \
+ nfs_mount4.h
+
+mount_nfs_LDADD = ../../support/nfs/libnfs.a
+
+MAINTAINERCLEANFILES = Makefile.in
+
+install-exec-hook:
+ (cd $(DESTDIR)$(sbindir) && \
+ ln -sf $(sbin_PROGRAMS) mount.nfs4 && \
+ ln -sf $(sbin_PROGRAMS) umount.nfs && \
+ ln -sf $(sbin_PROGRAMS) umount.nfs4)
+uninstall-hook:
+ (cd $(DESTDIR)$(sbindir) && \
+ rm -f mount.nfs4 umount.nfs umount.nfs4)
+
+
+install-man-links:
+ (cd $(DESTDIR)$(man8dir) && \
+ for m in $(man8_MANS) $(dist_man8_MANS) $(nodist_man8_MANS); do \
+ inst=`echo $$m | sed -e 's/man$$/8/'`; \
+ rm -f $$inst ; \
+ done)
+
+uninstall-man-links:
+ (cd $(DESTDIR)$(man8dir) && \
+ for m in $(man8_MANS) $(dist_man8_MANS) $(nodist_man8_MANS); do \
+ inst=`echo $$m | sed -e 's/man$$/8/'`; \
+ rm -f $$inst ; \
+ done)
+