summaryrefslogtreecommitdiffstats
path: root/utils/gssd/Makefile.am
diff options
context:
space:
mode:
authorJeff Layton <jlayton@redhat.com>2011-12-23 14:41:11 -0500
committerSteve Dickson <steved@redhat.com>2012-01-05 15:42:40 -0500
commit17e77da99f103191da3e1e7d0b43838a04c5ac3b (patch)
tree5ceea875f5eb246e9f55899045a377fe95cfe9ef /utils/gssd/Makefile.am
parentd33381555310aacaa9a5da05ccb3b156abea2971 (diff)
downloadnfs-utils-17e77da99f103191da3e1e7d0b43838a04c5ac3b.tar.gz
nfs-utils-17e77da99f103191da3e1e7d0b43838a04c5ac3b.tar.xz
nfs-utils-17e77da99f103191da3e1e7d0b43838a04c5ac3b.zip
autoconf: don't let libnfsidmap test add -lnfsidmap to $LIBS
...as that makes that library get linked into every binary. Also, replace "hardcoded" -lnfsidmap linker flag in Makefiles with a AC_SUBST variable. This fixes a regression introduced in commit d7c64dd. Signed-off-by: Jeff Layton <jlayton@redhat.com>
Diffstat (limited to 'utils/gssd/Makefile.am')
-rw-r--r--utils/gssd/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/gssd/Makefile.am b/utils/gssd/Makefile.am
index d7888ad..9136189 100644
--- a/utils/gssd/Makefile.am
+++ b/utils/gssd/Makefile.am
@@ -58,7 +58,7 @@ svcgssd_SOURCES = \
svcgssd_LDADD = \
../../support/nfs/libnfs.a \
- $(RPCSECGSS_LIBS) $(GSSGLUE_LIBS) -lnfsidmap \
+ $(RPCSECGSS_LIBS) $(GSSGLUE_LIBS) $(LIBNFSIDMAP) \
$(KRBLIBS)
svcgssd_LDFLAGS = $(KRBLDFLAGS)