summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Brown <neilb@suse.de>2007-02-12 12:25:03 +1100
committerNeil Brown <neilb@suse.de>2007-02-12 12:25:03 +1100
commite91ff0175602cc56f223f1d92de6511099fa40d1 (patch)
tree7d98e93a037f2986572659fa8d2ea2287317cd83 /configure.in
parentf981e46adaab5da3d105b5adf735e9ce9c19a1d5 (diff)
downloadnfs-utils-e91ff0175602cc56f223f1d92de6511099fa40d1.tar.gz
nfs-utils-e91ff0175602cc56f223f1d92de6511099fa40d1.tar.xz
nfs-utils-e91ff0175602cc56f223f1d92de6511099fa40d1.zip
Use UUIDs to identify filesystems if kernel supports it.
This introduces a new dependancy on libblkid. If a filesystem being exported has a UUID that libblkid can extract, then that is passed to the kernel for use in identifying the filesystem in filehandles. This means that 'fsid=' is no longer needed to work around the problem of device numbers changing. fsid= is still needed for fielsystems that have no device, and can now be given 16byute uuid instead of just a 32bit one.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 99adee8..59dc869 100644
--- a/configure.in
+++ b/configure.in
@@ -175,9 +175,12 @@ fi
if test "$knfsd_cv_glibc2" = no; then
AC_CHECK_LIB(bsd, daemon, [LIBBSD="-lbsd"])
fi
+AC_CHECK_LIB(blkid, blkid_get_cache, [LIBBLKID="-lblkid"], AC_MSG_ERROR([libblkid needed]))
+AC_CHECK_HEADER(blkid/blkid.h, , AC_MSG_ERROR([Cannot file libblkid header file blkid/blkid.h]))
AC_SUBST(LIBSOCKET)
AC_SUBST(LIBCRYPT)
AC_SUBST(LIBBSD)
+AC_SUBST(LIBBLKID)
if test "$enable_gss" = yes; then
dnl 'gss' also depends on nfsidmap.h - at least for svcgssd_proc.c