summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorneilbrown <neilbrown>2006-04-10 04:00:31 +0000
committerneilbrown <neilbrown>2006-04-10 04:00:31 +0000
commitaa2d7a1e352a6c2190452ebc3c638b66a2cf6f9b (patch)
treeb0257379420bfe483a5fea487cf610c6e52bc195 /configure.in
parentdad8bf9fdf53d1f954339567da2aa1d1bc202c73 (diff)
downloadnfs-utils-aa2d7a1e352a6c2190452ebc3c638b66a2cf6f9b.tar.gz
nfs-utils-aa2d7a1e352a6c2190452ebc3c638b66a2cf6f9b.tar.xz
nfs-utils-aa2d7a1e352a6c2190452ebc3c638b66a2cf6f9b.zip
2006-04-10 "Kevin Coffman" <kwc@citi.umich.edu>
Check for sufficient version of librpcsecgss and libgssapi in configure.in
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4d4d2f4..f4ef796 100644
--- a/configure.in
+++ b/configure.in
@@ -149,14 +149,15 @@ if test "$enable_nfsv4" = yes; then
AC_CHECK_HEADERS(event.h, ,[AC_MSG_ERROR(libevent needed for nfsv4 support)])
AC_CHECK_HEADERS(nfsidmap.h, ,[AC_MSG_ERROR(libnfsidmap needed for nfsv4 support)])
dnl librpcsecgss already has a dependency on libgssapi,
- dnl so we don't need to do an explicit check for libgssapi here
+ dnl but we need to make sure we get the right version
if test "$enable_gss" = yes; then
- PKG_CHECK_MODULES(RPCSECGSS, librpcsecgss, [],
+ PKG_CHECK_MODULES([RPCSECGSS], [librpcsecgss >= 0.10], [],
[AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.
If you have pkgconfig installed, you might try setting environment
variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])
]
)
+ PKG_CHECK_MODULES([GSSAPI], [libgssapi >= 0.9])
fi
fi