summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorneilbrown <neilbrown>2005-08-26 02:02:15 +0000
committerneilbrown <neilbrown>2005-08-26 02:02:15 +0000
commita1b7c0da9e73a607f4bc70ffe3b44b00f5d39938 (patch)
tree3dfb3efdb7e3a911c533134d87aab66966587da4 /configure.in
parent1d0397894463e507e9f5d92442ac3b09e29310a3 (diff)
downloadnfs-utils-a1b7c0da9e73a607f4bc70ffe3b44b00f5d39938.tar.gz
nfs-utils-a1b7c0da9e73a607f4bc70ffe3b44b00f5d39938.tar.xz
nfs-utils-a1b7c0da9e73a607f4bc70ffe3b44b00f5d39938.zip
Remove the rpcsec_gss code and rely on an external library instead.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8cd00df..8e239ab 100644
--- a/configure.in
+++ b/configure.in
@@ -223,6 +223,12 @@ if test "$enable_gss" = yes; then
AC_MSG_WARN(Using $KRBDIR instead of requested value of $krb5_with for Kerberos!)
fi
+ dnl This is not done until here because we need to have KRBLIB set
+ dnl "librpcsecgss=1" is so that it doesn't get added to LIBS
+ AC_CHECK_LIB(rpcsecgss, authgss_create_default, [librpcsecgss=1], [AC_MSG_ERROR(librpcsecgss needed for nfsv4 support)], $KRBLIB)
+ AC_CHECK_LIB(rpcsecgss, authgss_set_debug_level,
+ AC_DEFINE(HAVE_AUTHGSS_SET_DEBUG_LEVEL, 1, [Define this if the rpcsec_gss library has the function authgss_set_debug_level]),, $KRBLIB)
+
AC_SUBST([KRBDIR])
AC_SUBST([KRBLIB])
AC_SUBST([KRBINC])