summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAmit Gud <agud@redhat.com>2006-06-12 19:06:36 -0400
committerNeil Brown <neilb@suse.de>2006-06-16 12:18:55 +1000
commita0520fa1a41bd33815b331b660b4545f2723495c (patch)
tree01c5f70db5da8039cc87c181e8c315d9f8c87026 /configure.in
parentb9559d9cd6255ec3068d1c840361ad972e2e066e (diff)
downloadnfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.tar.gz
nfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.tar.xz
nfs-utils-a0520fa1a41bd33815b331b660b4545f2723495c.zip
Move NFS mount code from util-linux to nfs-utils - part 1
Adds the mount directory and the code to mount and umount the NFS file system. Signed-off-by: Amit Gud <agud@redhat.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7733077..5eb1d79 100644
--- a/configure.in
+++ b/configure.in
@@ -107,6 +107,13 @@ AC_ARG_ENABLE(rquotad,
fi
AM_CONDITIONAL(CONFIG_RQUOTAD, [test "$enable_rquotad" = "yes"])
+AC_ARG_WITH(mount,
+ [AC_HELP_STRING([--without-mount],
+ [Create mount.nfs and do not use the util-linux mount(8) functionality. By default it doesn't.])],
+ use_mount=$withval,
+ use_mount=yes)
+ AM_CONDITIONAL(CONFIG_NOMOUNT, [test "$use_mount" = "no"])
+
# Check whether user wants TCP wrappers support
AC_TCP_WRAPPERS
@@ -314,6 +321,7 @@ AC_CONFIG_FILES([
utils/gssd/Makefile
utils/idmapd/Makefile
utils/lockd/Makefile
+ utils/mount/Makefile
utils/mountd/Makefile
utils/nfsd/Makefile
utils/nfsstat/Makefile