summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorneilbrown <neilbrown>2006-03-28 00:53:30 +0000
committerneilbrown <neilbrown>2006-03-28 00:53:30 +0000
commit4b4f1c94d87475fd45bb17119a862adb17a067a9 (patch)
treeb96ac01f1a062ba42adf2cbfae959e5c726560ff /configure.in
parent7c0658702830ca9f4d019bbdca0d94fa657a0f17 (diff)
downloadnfs-utils-4b4f1c94d87475fd45bb17119a862adb17a067a9.tar.gz
nfs-utils-4b4f1c94d87475fd45bb17119a862adb17a067a9.tar.xz
nfs-utils-4b4f1c94d87475fd45bb17119a862adb17a067a9.zip
Use PKGCONFIG to locate gssapi and rpcsecgss header files
Instead of having separate copies of the gssapi and rpcsecgss header files, or depending on the Kerberos gssapi header, locate the headers now installed with the libgssapi and librpcsecgss libraries. Remove local copies of the gssapi and rpcsecgss header files. This depends on the configure_use_autotools patch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c971d2e..7ecf213 100644
--- a/configure.in
+++ b/configure.in
@@ -148,6 +148,15 @@ if test "$enable_nfsv4" = yes; then
AC_CHECK_LIB(nfsidmap, nfs4_init_name_mapping, [libnfsidmap=1], [AC_MSG_ERROR(libnfsidmap needed for nfsv4 support)])
AC_CHECK_HEADERS(event.h, ,[AC_MSG_ERROR(libevent needed for nfsv4 support)])
AC_CHECK_HEADERS(nfsidmap.h, ,[AC_MSG_ERROR(libnfsidmap needed for nfsv4 support)])
+ dnl librpcsecgss already has a dependency on libgssapi,
+ dnl so we don't need to do an explicit check for libgssapi here
+ PKG_CHECK_MODULES(RPCSECGSS, librpcsecgss, [],
+ [AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.
+ If you have pkgconfig installed, you might try setting environment
+ variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])
+ ]
+ )
+
fi
if test "$knfsd_cv_glibc2" = no; then
AC_CHECK_LIB(bsd, daemon, [LIBBSD="-lbsd"])
@@ -166,7 +175,7 @@ if test "$enable_gss" = yes; then
AC_KERBEROS_V5
dnl This is not done until here because we need to have KRBLIBS set
- dnl "librpcsecgss=1" is so that it doesn't get added to LIBS
+ dnl ("librpcsecgss=1" is so that it doesn't get added to LIBS)
AC_CHECK_LIB(rpcsecgss, authgss_create_default, [librpcsecgss=1], [AC_MSG_ERROR(librpcsecgss needed for nfsv4 support)], $KRBLIBS)
AC_CHECK_LIB(rpcsecgss, authgss_set_debug_level,
AC_DEFINE(HAVE_AUTHGSS_SET_DEBUG_LEVEL, 1, [Define this if the rpcsec_gss library has the function authgss_set_debug_level]),, $KRBLIBS)