summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Brown <neilb@suse.de>2007-03-20 11:15:29 +1100
committerNeil Brown <neilb@suse.de>2007-03-20 11:15:29 +1100
commit453ac684258684e0e8413f4d9ef9822e753d9dbb (patch)
tree1ea32446cb7bdf042bbe888d06c0486fb86d99a3 /configure.in
parent390e67de5d9fe919d1894359536f0c5527fa2331 (diff)
downloadnfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.tar.gz
nfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.tar.xz
nfs-utils-453ac684258684e0e8413f4d9ef9822e753d9dbb.zip
Add --with-rpcgen= for configure so that the system rpcgen can be used.
Ultimately it makes sense to remove remove rpcgen from the nfs-utils release as it is already in the glibc release. With this patch you can use the system rpcgen to make sure it works. It is not default yet, but it might be in a future release.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4f64523..1240656 100644
--- a/configure.in
+++ b/configure.in
@@ -115,7 +115,16 @@ AC_ARG_ENABLE(rquotad,
RQUOTAD=
fi
AM_CONDITIONAL(CONFIG_RQUOTAD, [test "$enable_rquotad" = "yes"])
-
+AC_ARG_WITH(rpcgen,
+ [AC_HELP_STRING([--with-rpcgen=/usr/bin/rpcgen], [use system rpcgen instead of compiling our own])],
+ if test "$withval" == "yes"; then
+ for p in /usr/local/bin/rpcgen /usr/bin/rpcgen /bin/rpcgen
+ do if test -f $p ; then withval=$p ; break; fi ; done
+ fi
+ RPCGEN_PATH=$withval,
+ RPCGEN_PATH= )
+ AC_SUBST(RPCGEN_PATH)
+ AM_CONDITIONAL(CONFIG_RPCGEN, [test "$RPCGEN_PATH" == ""])
AC_ARG_ENABLE(mount,
[AC_HELP_STRING([--enable-mount],
[Create mount.nfs and don't use the util-linux mount(8) functionality. @<:@default=no@:>@])],