summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGreg Banks <gnb@melbourne.sgi.com>2006-06-22 17:16:19 +1000
committerGreg Banks <gnb@melbourne.sgi.com>2006-06-22 17:16:19 +1000
commit24d303ffae686192bda0a5996e8590219dcc82e7 (patch)
treef5f4601e2293556872d6efc0de8ee66b95d79142 /configure.in
parent66a699d953727d3a992cc09ed5304b83d661a737 (diff)
downloadnfs-utils-24d303ffae686192bda0a5996e8590219dcc82e7.tar.gz
nfs-utils-24d303ffae686192bda0a5996e8590219dcc82e7.tar.xz
nfs-utils-24d303ffae686192bda0a5996e8590219dcc82e7.zip
Do m4 quoting of AC_MSG_ERROR() and AC_MSG_WARN() as
the autoconf people intended. This avoids errors in autoconf on SLES10.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 5eb1d79..bcac7d8 100644
--- a/configure.in
+++ b/configure.in
@@ -151,17 +151,17 @@ AC_CHECK_LIB(socket, main, [LIBSOCKET="-lnsl"])
AC_CHECK_LIB(nsl, main, [LIBNSL="-lnsl"])
AC_CHECK_LIB(crypt, crypt, [LIBCRYPT="-lcrypt"])
if test "$enable_nfsv4" = yes; then
- AC_CHECK_LIB(event, event_dispatch, [libevent=1], [AC_MSG_ERROR(libevent needed for nfsv4 support)])
- AC_CHECK_LIB(nfsidmap, nfs4_init_name_mapping, [libnfsidmap=1], [AC_MSG_ERROR(libnfsidmap needed for nfsv4 support)])
- AC_CHECK_HEADERS(event.h, ,[AC_MSG_ERROR(libevent needed for nfsv4 support)])
- AC_CHECK_HEADERS(nfsidmap.h, ,[AC_MSG_ERROR(libnfsidmap needed for nfsv4 support)])
+ AC_CHECK_LIB(event, event_dispatch, [libevent=1], AC_MSG_ERROR([libevent needed for nfsv4 support]))
+ AC_CHECK_LIB(nfsidmap, nfs4_init_name_mapping, [libnfsidmap=1], AC_MSG_ERROR([libnfsidmap needed for nfsv4 support]))
+ AC_CHECK_HEADERS(event.h, ,AC_MSG_ERROR([libevent needed for nfsv4 support]))
+ AC_CHECK_HEADERS(nfsidmap.h, ,AC_MSG_ERROR([libnfsidmap needed for nfsv4 support]))
dnl librpcsecgss already has a dependency on libgssapi,
dnl but we need to make sure we get the right version
if test "$enable_gss" = yes; then
PKG_CHECK_MODULES([RPCSECGSS], [librpcsecgss >= 0.10], [],
- [AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.
- If you have pkgconfig installed, you might try setting environment
- variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])
+ [AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.])
+ AC_MSG_ERROR([If you have pkgconfig installed, you might try setting environment])
+ AC_MSG_ERROR([variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])
]
)
PKG_CHECK_MODULES([GSSAPI], [libgssapi >= 0.9])
@@ -178,15 +178,15 @@ AC_SUBST(LIBBSD)
if test "$enable_gss" = yes; then
dnl 'gss' also depends on nfsidmap.h - at least for svcgssd_proc.c
- AC_CHECK_HEADERS(nfsidmap.h, ,[AC_MSG_ERROR(libnfsidmap needed for gss support)])
- AC_CHECK_HEADERS(spkm3.h, ,[AC_MSG_WARN(could not locate SPKM3 header; will not have SPKM3 support)])
+ AC_CHECK_HEADERS(nfsidmap.h, ,AC_MSG_ERROR([libnfsidmap needed for gss support]))
+ AC_CHECK_HEADERS(spkm3.h, ,AC_MSG_WARN([could not locate SPKM3 header; will not have SPKM3 support]))
dnl Check for Kerberos V5
AC_KERBEROS_V5
dnl This is not done until here because we need to have KRBLIBS set
dnl ("librpcsecgss=1" is so that it doesn't get added to LIBS)
- AC_CHECK_LIB(rpcsecgss, authgss_create_default, [librpcsecgss=1], [AC_MSG_ERROR(librpcsecgss needed for nfsv4 support)], $KRBLIBS)
+ AC_CHECK_LIB(rpcsecgss, authgss_create_default, [librpcsecgss=1], AC_MSG_ERROR([librpcsecgss needed for nfsv4 support]), $KRBLIBS)
AC_CHECK_LIB(rpcsecgss, authgss_set_debug_level,
AC_DEFINE(HAVE_AUTHGSS_SET_DEBUG_LEVEL, 1, [Define this if the rpcsec_gss library has the function authgss_set_debug_level]),, $KRBLIBS)