summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-03-26 11:11:41 -0400
committerSimo Sorce <simo@redhat.com>2013-03-26 12:15:19 -0400
commitdf16cc255bf2d208a61c7d9810e3be6685b697a6 (patch)
tree559b135388fa1fde8a76f6c3fbb8426a4c72ecc3 /configure.ac
parente79baddaa1d8cf24cce929e14f6f91ac0d5e15d0 (diff)
downloadnfs-utils-df16cc255bf2d208a61c7d9810e3be6685b697a6.tar.gz
nfs-utils-df16cc255bf2d208a61c7d9810e3be6685b697a6.tar.xz
nfs-utils-df16cc255bf2d208a61c7d9810e3be6685b697a6.zip
Switch to use standard GSSAPI by default
Make libgssglue configurable still but disabled by default. There is no reason to use libgssglue anymore, and modern gssapi supports all needed features for nfs-utils. Signed-off-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc7f3b4..3d7ab0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,15 @@ if test "$enable_gss" = yes; then
dnl but we need to make sure we get the right version
if test "$enable_gss" = yes; then
AC_RPCSEC_VERSION
+ if test x"$GSSGLUE_LIBS" != x""; then
+ GSSAPI_CFLAGS=$GSSGLUE_CFLAGS
+ GSSAPI_LIBS=$GSSGLUE_LIBS
+ else
+ GSSAPI_CFLAGS=$GSSKRB_CFLAGS
+ GSSAPI_LIBS=$GSSKRB_LIBS
+ fi
+ AC_SUBST([GSSAPI_CFLAGS])
+ AC_SUBST([GSSAPI_LIBS])
fi
fi