summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2011-09-22 14:47:09 -0400
committerSteve Dickson <steved@redhat.com>2011-09-22 14:48:08 -0400
commit6b9d7ab4df98cf9881c7cc4341631eec25bb0e26 (patch)
treea52c33fc5ebd618459d347090e8eb5fbf335bd37 /configure.ac
parent4ee1190080fbb8cdd5ed2bef7c00a04799650b1b (diff)
downloadnfs-utils-6b9d7ab4df98cf9881c7cc4341631eec25bb0e26.tar.gz
nfs-utils-6b9d7ab4df98cf9881c7cc4341631eec25bb0e26.tar.xz
nfs-utils-6b9d7ab4df98cf9881c7cc4341631eec25bb0e26.zip
blkmapd: Add complex block layout discovery and mapping daemon
This daemon is required to handle upcalls from the kernel pnfs block layout driver. Signed-off-by: Jim Rees <rees@umich.edu> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 500172b..d85ab21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,13 +84,15 @@ AC_ARG_ENABLE(nfsv4,
AC_ARG_ENABLE(nfsv41,
[AC_HELP_STRING([--enable-nfsv41],
- [enable support for NFSv41 @<:@default=no@:>@])],
+ [enable support for NFSv41 @<:@default=yes@:>@])],
enable_nfsv41=$enableval,
- enable_nfsv41=no)
+ enable_nfsv41=yes)
if test "$enable_nfsv41" = yes; then
+ BLKMAPD=blkmapd
AC_DEFINE(NFS41_SUPPORTED, 1, [Define this if you want NFSv41 support compiled in])
else
enable_nfsv41=
+ BLKMAPD=
fi
AC_SUBST(enable_nfsv41)
AM_CONDITIONAL(CONFIG_NFSV41, [test "$enable_nfsv41" = "yes"])
@@ -460,6 +462,7 @@ AC_CONFIG_FILES([
tools/mountstats/Makefile
tools/nfs-iostat/Makefile
utils/Makefile
+ utils/blkmapd/Makefile
utils/exportfs/Makefile
utils/gssd/Makefile
utils/idmapd/Makefile