summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2012-08-06 09:08:53 -0400
committerSteve Dickson <steved@redhat.com>2012-08-06 09:11:27 -0400
commit41f32cd96eca95a2730603ebc539440c48a1dda5 (patch)
tree892c0b4b4cb4fc1c4e627aca64c33fe8ff69e067 /configure.ac
parente4e5dadd7685415059173e438a5710a9e51ffbff (diff)
downloadnfs-utils-41f32cd96eca95a2730603ebc539440c48a1dda5.tar.gz
nfs-utils-41f32cd96eca95a2730603ebc539440c48a1dda5.tar.xz
nfs-utils-41f32cd96eca95a2730603ebc539440c48a1dda5.zip
rpc.gssd: don't call poll(2) twice a second
Use ppoll() instead. [ cel Wed Aug 1 11:44:46 EDT 2012 - autoconfiscated Bruce's version ] Related clean-up: Since we're pulling the poll/ppoll call out into a separate function, note that the second argument of poll(2) and ppoll(2) is not an int, it's an unsigned long. The nfds_t typedef is a recent invention, so use the raw type for compatibility with older glibc headers. Acked-by: J. Bruce Fields" <bfields@redhat.com> Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b408f1b..18ee11a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -392,7 +392,7 @@ AC_CHECK_FUNCS([alarm atexit dup2 fdatasync ftruncate getcwd \
gethostbyaddr gethostbyname gethostname getmntent \
getnameinfo getrpcbyname getifaddrs \
gettimeofday hasmntopt inet_ntoa innetgr memset mkdir pathconf \
- realpath rmdir select socket strcasecmp strchr strdup \
+ ppoll realpath rmdir select socket strcasecmp strchr strdup \
strerror strrchr strtol strtoul sigprocmask])