summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2014-02-15 15:59:06 -0500
committerSimo Sorce <simo@redhat.com>2014-02-15 16:45:39 -0500
commit4b6ed2bfeeb912272e57fe9365cb175fd06ed6b0 (patch)
treefe5f208da61b402ed6ad9e7bce1e83dc8802ace2 /src/Makefile.am
parent4758b76d90376d6a861dde76f9bf48b420c87d67 (diff)
downloadmod_auth_gssapi-4b6ed2bfeeb912272e57fe9365cb175fd06ed6b0.tar.gz
mod_auth_gssapi-4b6ed2bfeeb912272e57fe9365cb175fd06ed6b0.tar.xz
mod_auth_gssapi-4b6ed2bfeeb912272e57fe9365cb175fd06ed6b0.zip
Add initial configure scripts
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..a725b52
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,25 @@
+MAG_CFLAGS = @APR_CPPFLAGS@ @APXS_CPPFLAGS@ @APXS_CPPFLAGS_SHLIB@
+MAG_INCLUDES = @INCLTDL@ @APR_INCLUDES@ @APXS_INCLUDES@
+MAG_LIBS = @LIBLTDL@ @APR_LDFLAGS@ @APXS_LDFLAGS@ @APXS_LIBS@ @APXS_LD_SHLIB@
+MAG_LIBEXECDIR = @APXS_LIBEXECDIR@
+
+if HAVE_GCC
+ MAG_CFLAGS += -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith \
+ -Wcast-qual -Wcast-align -Wwrite-strings \
+ -Werror-implicit-function-declaration \
+ -fno-strict-aliasing
+endif
+
+lib_LTLIBRARIES = mod_auth_gssapi.la
+
+mod_auth_gssapi_la_LDFLAGS = -module
+
+mod_auth_gssapi.la: mod_auth_gssapi.c
+ @APXS@ -c ${LIBS} -Wc,"${MAG_CFLAGS} ${MAG_INCLUDES}" -Wl,"${MAG_LIBS}" mod_auth_gssapi.c
+
+install: mod_auth_gssapi.la
+ if test ! -d ${MAG_LIBEXECDIR}; then mkdir -p ${MAG_LIBEXECDIR}; fi
+ @APXS@ -i -S LIBEXECDIR=${MAG_LIBEXECDIR} mod_auth_gssapi.la
+
+clean-local:
+ rm -f mod_auth_gssapi.slo mod_auth_gssapi.la mod_auth_gssapi.lo .libs