summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2015-03-10 12:23:12 -0400
committerSimo Sorce <simo@redhat.com>2015-03-10 15:27:12 -0400
commit3effbe272147674cf92c13b387373a60f2cbbacf (patch)
tree9a933e4ab27b17e5759f52737d3432c555ad4aaf /configure.ac
parent2b95bf742f097b419b4e63ef74f33fc121c91bf0 (diff)
downloadmod_auth_gssapi-3effbe272147674cf92c13b387373a60f2cbbacf.tar.gz
mod_auth_gssapi-3effbe272147674cf92c13b387373a60f2cbbacf.tar.xz
mod_auth_gssapi-3effbe272147674cf92c13b387373a60f2cbbacf.zip
Improve Basic Auth based logins
Set a per-thread Credentials Cache Name that will be thrown away once authentication is done. This handles both an issue with stomping on ccaches if two authentications happen in concurrent threads, as well as issues with gss_acquire_cred_with_password() reusing the ccache without actually performing an AS request. Fixes #11
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 78f31a2..7be2b7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,7 +53,8 @@ PKG_CHECK_MODULES([OPENSSL], [openssl])
AC_SUBST([OPENSSL_CFLAGS])
AC_SUBST([OPENSSL_LIBS])
-AC_CHECK_HEADERS([gssapi/gssapi.h],,[AC_MSG_ERROR([Could not find GSSAPI headers])])
+AC_CHECK_HEADERS([gssapi/gssapi.h gssapi/gssapi_ext.h gssapi/gssapi_krb5.h],
+ ,[AC_MSG_ERROR([Could not find GSSAPI headers])])
AC_PATH_PROG(KRB5_CONFIG, krb5-config, failed)
if test x$KRB5_CONFIG = xfailed; then
AC_MSG_ERROR([Could not find GSSAPI development libraries])
@@ -66,6 +67,7 @@ AC_CHECK_LIB([gssapi_krb5], [gss_accept_sec_context], [],
AC_CHECK_FUNCS(gss_acquire_cred_from)
AC_CHECK_FUNCS(gss_store_cred_into)
AC_CHECK_FUNCS(gss_acquire_cred_with_password)
+AC_CHECK_FUNCS(gss_krb5_ccache_name)
AC_SUBST([GSSAPI_CFLAGS])
AC_SUBST([GSSAPI_LIBS])