summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 00000000..62d9c289
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,22 @@
+if WITH_TESTS
+
+TESTS = login_tests
+noinst_PROGRAMS = login_tests
+
+INCLUDES = \
+ -DPACKAGE=\"@PACKAGE@\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lasso \
+ $(LASSO_DEFINES) \
+ $(LASSO_CFLAGS) \
+ $(CHECK_CFLAGS)
+
+login_tests_SOURCES = login_tests.c
+login_tests_LDADD = \
+ $(top_builddir)/lasso/liblasso.la \
+ $(LASSO_LIBS) \
+ $(CHECK_LIBS)
+endif
+
+EXTRA_DIST = login_tests.c
+