summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0865278e..688292fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -615,10 +615,6 @@ else
fi
AC_SUBST(HTML_DIR)
-AC_CHECK_PROGS(REST2HTML, rest2html)
-
-AM_CONDITIONAL(HAVE_REST2HTML, test -n "$ac_cv_prog_REST2HTML")
-
dnl pkg-config path
AC_ARG_WITH(pkg-config, [ --with-pkg-config=PATH set pkg-config metadata search path.],
@@ -641,6 +637,17 @@ fi
dnl Conditional docs sub dir test.
AM_CONDITIONAL([GTK_DOC_ENABLED],[test "x$enable_gtk_doc" = "xyes"])
+
+AC_CHECK_PROGS(REST2HTML, rest2html)
+AM_CONDITIONAL(HAVE_REST2HTML, test -n "$ac_cv_prog_REST2HTML")
+
+AC_CHECK_PROGS(XSLTPROC, xsltproc)
+AM_CONDITIONAL(HAVE_XSLTPROC, test -n "$ac_cv_prog_XSLTPROC")
+
+AC_CHECK_PROGS(INKSCAPE, inkscape)
+AM_CONDITIONAL(HAVE_INKSCAPE, test -n "$ac_cv_prog_INKSCAPE")
+
+
dnl Debug
AC_MSG_CHECKING(for debugging)
AC_ARG_ENABLE(debugging, [ --enable-debugging enable debuging messages (no)])