summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-09-04 09:44:34 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-09-04 09:44:34 +0000
commit24430806e6761766e6cd8a309a0c087dd90f178e (patch)
tree60eae733db473ed68d38477df531a5e5d7a58a3c /tests/Makefile.am
parentdd0e7143ee7f16db21a9c7fe9abfef4d297e0697 (diff)
downloadlasso-24430806e6761766e6cd8a309a0c087dd90f178e.tar.gz
lasso-24430806e6761766e6cd8a309a0c087dd90f178e.tar.xz
lasso-24430806e6761766e6cd8a309a0c087dd90f178e.zip
Fix regression when loading a LassoServer from dump.
Fix an error with -rpath setting in last commit, -rpath must always be absolute paths.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d2461ca8..c2785a49 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -18,11 +18,11 @@ tests_LDADD = \
$(top_builddir)/lasso/liblasso.la \
$(LASSO_LIBS) \
$(CHECK_LIBS)
-tests_LDFLAGS = -rpath $(top_srcdir)/lasso/.libs/
+tests_LDFLAGS = -rpath `cd $(top_srcdir)/lasso/.libs/; pwd`
perfs_SOURCES = perfs.c
perfs_LDADD = $(top_builddir)/lasso/liblasso.la $(LASSO_LIBS)
-perfs_LDFLAGS = -rpath $(top_srcdir)/lasso/.libs/
+perfs_LDFLAGS = -rpath `cd $(top_srcdir)/lasso/.libs/; pwd`
endif