summaryrefslogtreecommitdiffstats
path: root/python/setup.py
diff options
context:
space:
mode:
authorValery Febvre <vfebvre at easter-eggs.com>2004-05-28 14:16:37 +0000
committerValery Febvre <vfebvre at easter-eggs.com>2004-05-28 14:16:37 +0000
commitc15a5d6e8e9392790ca558fbd2f69d75c71f10fb (patch)
tree3f84ee540b75271c019400ec2fd3249198b7b9c6 /python/setup.py
parent5f2d1654a5a69438dba932456932053c32f7ef19 (diff)
downloadlasso-c15a5d6e8e9392790ca558fbd2f69d75c71f10fb.tar.gz
lasso-c15a5d6e8e9392790ca558fbd2f69d75c71f10fb.tar.xz
lasso-c15a5d6e8e9392790ca558fbd2f69d75c71f10fb.zip
Added option menu to build documentation (doxygen)
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py16
1 files changed, 10 insertions, 6 deletions
diff --git a/python/setup.py b/python/setup.py
index 260e2714..53f4ce1b 100755
--- a/python/setup.py
+++ b/python/setup.py
@@ -49,10 +49,11 @@ if not hasattr(sys, 'version_info') or sys.version_info < (2,2):
# sanity check for any arguments
if len(sys.argv) == 1:
msg = 'Choose an action :\n' \
- ' 1. Build\n' \
- ' 2. Install\n' \
- ' 3. Clean\n' \
- ' 4. Exit\n' \
+ ' 1. Build module\n' \
+ ' 2. Build documentation\n' \
+ ' 3. Install\n' \
+ ' 4. Clean\n' \
+ ' 5. Exit\n' \
'Your choice : '
reply = raw_input(msg)
choice = None
@@ -61,11 +62,14 @@ if len(sys.argv) == 1:
if choice == '1':
sys.argv.append('build')
elif choice == '2':
- sys.argv.append('install')
+ print commands.getoutput('doxygen doc/doxygen.conf')
+ sys.exit(0)
elif choice == '3':
+ sys.argv.append('install')
+ elif choice == '4':
sys.argv.append('clean')
sys.argv.append('-a')
- elif choice == '4':
+ elif choice == '5':
sys.exit(0)
# the crypto engine name : openssl, gnutls or nss