summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorRomain Chantereay <rchantereau@entrouvert.com>2004-08-19 08:48:45 +0000
committerRomain Chantereay <rchantereau@entrouvert.com>2004-08-19 08:48:45 +0000
commit7dc6fd4dac5ac187b595dda61811f4445af85537 (patch)
tree3f2dfc06df622617f9adaf3b236730dffde10f5b /python/Makefile.am
parent7c21342696a1b94957755866be1731fe5186c0d9 (diff)
downloadlasso-7dc6fd4dac5ac187b595dda61811f4445af85537.tar.gz
lasso-7dc6fd4dac5ac187b595dda61811f4445af85537.tar.xz
lasso-7dc6fd4dac5ac187b595dda61811f4445af85537.zip
Now python binding is handled by SWIG. Manou takes the following parts.
All the file in the python directory except Makefile.am are useless now; but I do not remove it.
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am72
1 files changed, 44 insertions, 28 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 485b0f13..4a450524 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -1,29 +1,45 @@
-SUBDIRS = doc environs examples protocols tests xml
-
-lassomod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/lasso/.libs
-
-INCLUDES = \
- -DPACKAGE=\"@PACKAGE@\" \
- -I$(top_srcdir) \
- -I$(top_srcdir)/lasso \
- $(LASSO_DEFINES) \
- $(LASSO_CFLAGS) \
- $(PY_CFLAGS)
-
-pythondir = $(PY_SITE_PACKAGES)
-python_LTLIBRARIES = lassomod.la
-python_DATA = lasso.py lasso_strings.py
-
-mylibs = $(top_builddir)/lasso/liblasso.la
-
-lassomod_la_SOURCES = lassomod.c py_lasso.c utils.c wrap_objs.c
-lassomod_la_LIBADD = $(mylibs) \
- ./protocols/elements/libelements.la \
- ./protocols/libprotocols.la \
- ./xml/libxml.la \
- ./environs/libenvirons.la
-
-EXTRA_DIST = lassomod.h py_lasso.h utils.h wrap_objs.h \
- generator_lasso_strings.py lasso.py lasso_strings.py \
- lassomod.c py_lasso.c utils.c wrap_objs.c
+NULL=
+
+INCLUDES=-I$(top_srcdir)
+
+pythondir= $(PY_SITE_PACKAGES)
+python_DATA=lassomod.py
+python_LTLIBRARIES=_lassomod.la
+
+PYTHON_PACKAGE=lassomod
+_lassomod_la_SOURCES=$(PYTHON_PACKAGE)_wrap.c
+_lassomod_la_CFLAGS= $(LASSO_CFLAGS) \
+ -DSWIG_COBJECT_TYPES \
+ $(PY_CFLAGS) \
+ $(NULL)
+_lassomod_la_LIBADD= $(top_srcdir)/lasso/liblasso.la \
+ $(LASSO_LIBS) \
+ $(NULL)
+_lassomod_la_LDFLAGS= -module -avoid-version \
+ -version-info @LASSO_VERSION_INFO@ \
+ $(NULL)
+
+$(PYTHON_PACKAGE)_wrap.c: $(srcdir)/../swig/Lasso.i
+ swig -v -python -module $(PYTHON_PACKAGE) -o $@ $<
+
+# Dirty hack, another better way ?
+.deps/_$(PYTHON_PACKAGE)_la-$(PYTHON_PACKAGE)_wrap.Plo:
+ mkdir -p .deps
+ echo "#dummy" > .deps/_$(PYTHON_PACKAGE)_la-$(PYTHON_PACKAGE)_wrap.Plo
+
+SWIG_OUTPUTS=$(PYTHON_PACKAGE)_wrap.c $(PYTHON_PACKAGE).py
+
+
+SUBDIRS= \
+ $(NULL)
+
+# In distribution, swig generated files are present.
+EXTRA_DIST= $(SWIG_OUTPUTS)\
+ $(NULL)
+
+# In case of....
+CLEANFILES=lassomod.pyc
+
+# Maintainer clean the swig generated files, because he/she maintains them.
+MAINTAINERCLEANFILES=$(SWIG_OUTPUTS)