summaryrefslogtreecommitdiffstats
path: root/php/Makefile.am
diff options
context:
space:
mode:
authorChristophe Nowicki <cnowicki@easter-eggs.com>2004-08-05 15:26:38 +0000
committerChristophe Nowicki <cnowicki@easter-eggs.com>2004-08-05 15:26:38 +0000
commitb12193e68f822203ac01ea81055aebfb45b82544 (patch)
tree01568422b1bc06ebe66eee489611fc2794e380f5 /php/Makefile.am
parent8ecc49afbd5a6d860d5de1b170ef8e81e6a58fea (diff)
downloadlasso-b12193e68f822203ac01ea81055aebfb45b82544.tar.gz
lasso-b12193e68f822203ac01ea81055aebfb45b82544.tar.xz
lasso-b12193e68f822203ac01ea81055aebfb45b82544.zip
automake/autoconf support for the php binding
Diffstat (limited to 'php/Makefile.am')
-rw-r--r--php/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/php/Makefile.am b/php/Makefile.am
new file mode 100644
index 00000000..04a85472
--- /dev/null
+++ b/php/Makefile.am
@@ -0,0 +1,29 @@
+SUBDIRS = environs tests xml
+
+PHP_PACKAGE=lasso
+
+liblasso_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/lasso/.libs $(PHP_LDFLAGS)
+
+INCLUDES = \
+ -DPACKAGE=\"@PACKAGE@\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/lasso \
+ $(LASSO_DEFINES) \
+ $(LASSO_CFLAGS) \
+ $(PHP_INCLUDES) \
+ $(NULL)
+
+
+mylibs = $(top_builddir)/lasso/liblasso.la
+
+LASSOSOURCES = lasso.c lasso.h php_lasso.h
+
+lib_LTLIBRARIES = liblasso.la \
+ $(NULL)
+
+liblasso_la_SOURCES = $(LASSOSOURCES)
+liblasso_la_LIBADD = $(mylibs) \
+ ./environs/libenvirons.a \
+ ./xml/libxml.a \
+ $(PHP_LIBS) \
+ $(NULL)