summaryrefslogtreecommitdiffstats
path: root/lasso/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-05-22 14:54:13 +0000
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2008-05-22 14:54:13 +0000
commitc56b3083884efe515a8db3aca863cec0b9c17559 (patch)
tree9dbb7bec8f3676640b1fda6d4af23a17ab1d480f /lasso/Makefile.am
parente741a80a7fd35e91c522f97d9082e9f42784d115 (diff)
downloadlasso-c56b3083884efe515a8db3aca863cec0b9c17559.tar.gz
lasso-c56b3083884efe515a8db3aca863cec0b9c17559.tar.xz
lasso-c56b3083884efe515a8db3aca863cec0b9c17559.zip
add a new headers <lasso/utils.h> with macros to handle memory like assigning a
gobject field (work flow, is you augment ref of the new value, decrease the one from the old, and then assign), assigning strings, releasing lists of strings, of gobjects,etc.. the free macros are all called g_release_somehting and they set the released variable to NULL. add a macro to validate GObject parameter types This header is intended to concentre every bit of wisdom for handling pointers and memory, try to use thoses macros in your code. They are not intended to work with weak references (references you do not own), so always g_object_ref in this case (or use g_assign_gobject that does it, when your variable is not needed anymore to g_assign_gobject(var, NULL));
Diffstat (limited to 'lasso/Makefile.am')
-rw-r--r--lasso/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lasso/Makefile.am b/lasso/Makefile.am
index 34362692..9199336f 100644
--- a/lasso/Makefile.am
+++ b/lasso/Makefile.am
@@ -34,7 +34,7 @@ symbols.sym:
clean-local:
-rm types.c symbols.sym
-EXTRA_DIST = extract_types.py extract_symbols.py
+EXTRA_DIST = utils.h extract_types.py extract_symbols.py
if WSF_ENABLED
WSF_LIB_FILE = $(top_builddir)/lasso/id-wsf/liblasso-id-wsf.la