summaryrefslogtreecommitdiffstats
path: root/lasso/Makefile.am
diff options
context:
space:
mode:
authorRomain Chantereay <rchantereau@entrouvert.com>2004-08-05 15:12:06 +0000
committerRomain Chantereay <rchantereau@entrouvert.com>2004-08-05 15:12:06 +0000
commitb29c3b78c49577c287910dd00397dfbbfd2d2dd0 (patch)
tree6578de0c199097558d0d5b906568ac00346cc4ff /lasso/Makefile.am
parent491d441e659853ca52c67730c2f7d8449cdd9fa6 (diff)
downloadlasso-b29c3b78c49577c287910dd00397dfbbfd2d2dd0.tar.gz
lasso-b29c3b78c49577c287910dd00397dfbbfd2d2dd0.tar.xz
lasso-b29c3b78c49577c287910dd00397dfbbfd2d2dd0.zip
Remove command line PACKAGE definition (already done in lasso_config.h).
Diffstat (limited to 'lasso/Makefile.am')
-rw-r--r--lasso/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/lasso/Makefile.am b/lasso/Makefile.am
index 29d019c8..09c75bd8 100644
--- a/lasso/Makefile.am
+++ b/lasso/Makefile.am
@@ -4,7 +4,6 @@ SUBDIRS = xml protocols environs
liblassoincludedir = $(includedir)/lasso
INCLUDES = \
- -DPACKAGE=\"@PACKAGE@\" \
-I$(top_srcdir) \
-I$(top_srcdir)/lasso \
$(LASSO_DEFINES) \
@@ -54,6 +53,9 @@ liblasso_la_LIBADD = \
$(NULL)
endif
+# Just make damn sure the ABI stays the same between
+# upgrades.
+# Obviously if you don't, fixing the situation up again can be painful.
liblasso_la_LDFLAGS = \
-no-undefined -version-info @LASSO_VERSION_INFO@ \
$(NULL)