summaryrefslogtreecommitdiffstats
path: root/lasso/Makefile.am
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2004-12-21 14:00:17 +0000
committerFrederic Peters <fpeters@entrouvert.com>2004-12-21 14:00:17 +0000
commit513442f6c073b101a6ba2da924ba9562dfd50adf (patch)
treeb80f195a8634261d3cf47e957217c43e6062da78 /lasso/Makefile.am
parentd96583847854d9bcaa25f5184e07c2983b6e3fa7 (diff)
downloadlasso-513442f6c073b101a6ba2da924ba9562dfd50adf.tar.gz
lasso-513442f6c073b101a6ba2da924ba9562dfd50adf.tar.xz
lasso-513442f6c073b101a6ba2da924ba9562dfd50adf.zip
only exports symbols declared with LASSO_EXPORT (experimental)
Diffstat (limited to 'lasso/Makefile.am')
-rw-r--r--lasso/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/lasso/Makefile.am b/lasso/Makefile.am
index 49871098..6a09388e 100644
--- a/lasso/Makefile.am
+++ b/lasso/Makefile.am
@@ -17,17 +17,20 @@ lasso.rc.lo: $(top_srcdir)/win32/lasso.rc
lib_LTLIBRARIES = liblasso.la
liblassoinclude_HEADERS = export.h lasso.h lasso_config.h
-BUILT_SOURCES = types.c
+BUILT_SOURCES = types.c symbols.sym
liblasso_la_SOURCES = lasso.c
types.c:
python extract_types.py
+symbols.sym:
+ python extract_symbols.py > symbols.sym
+
clean-local:
- -rm types.c
+ -rm types.c symbols.sym
-EXTRA_DIST = extract_types.py
+EXTRA_DIST = extract_types.py extract_symbols.py
if MINGW
liblasso_la_LIBADD = \
@@ -50,7 +53,7 @@ liblasso_la_LIBADD = \
# Just make damn sure the ABI stays the same between
# upgrades.
# Obviously if you don't, fixing the situation up again can be painful.
-liblasso_la_LDFLAGS = -no-undefined -version-info @LASSO_VERSION_INFO@
+liblasso_la_LDFLAGS = -no-undefined -version-info @LASSO_VERSION_INFO@ \
+ -export-symbols symbols.sym
endif
-