summaryrefslogtreecommitdiffstats
path: root/csharp/Makefile.am
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2004-08-21 11:23:53 +0000
committerFrederic Peters <fpeters@entrouvert.com>2004-08-21 11:23:53 +0000
commita2d62912686dd17b3670995a06ac1f0abb91fdf1 (patch)
tree43181f511e952f405b6e3276d3f09bf6f4e32b23 /csharp/Makefile.am
parent188b4dfd364c17e1fe367d5cea14805918e105fa (diff)
downloadlasso-a2d62912686dd17b3670995a06ac1f0abb91fdf1.tar.gz
lasso-a2d62912686dd17b3670995a06ac1f0abb91fdf1.tar.xz
lasso-a2d62912686dd17b3670995a06ac1f0abb91fdf1.zip
added c# binding; I'm not sure how all of this works and a little program
compiles and run: using System; public class runme { static void Main() { Console.WriteLine("lasso_init"); int rc = lassomod.lasso_init(); Console.WriteLine(String.Format("sortie de lasso_init: {0}", rc)); LassoServer server = new LassoServer( "../tests/data/idp1-la/metadata.xml", "", "../tests/data/idp1-la/private-key-raw.pem", "../tests/data/idp1-la/certificate.pem", lassomod.lassoSignatureMethodRsaSha1); Console.WriteLine("lasso_shutdown"); lassomod.lasso_shutdown(); } }
Diffstat (limited to 'csharp/Makefile.am')
-rw-r--r--csharp/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/csharp/Makefile.am b/csharp/Makefile.am
new file mode 100644
index 00000000..0c8a375b
--- /dev/null
+++ b/csharp/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = -I$(top_srcdir)
+
+csharp_LTLIBRARIES = lassomod.la
+csharpdir = /tmp
+
+lassomod_la_SOURCES = lassomod_wrap.c \
+ $(top_srcdir)/swig/Lasso.c
+
+lassomod_la_CFLAGS = $(LASSO_CFLAGS) \
+ -DSWIG_COBJECT_TYPES
+
+lassomod_la_LIBADD = $(top_builddir)/lasso/liblasso.la \
+ $(LASSO_LIBS)
+
+lassomod_la_LDFLAGS = -no-undefined -module -avoid-version
+
+lassomod_wrap.c: $(top_srcdir)/swig/Lasso.i
+ $(SWIG) -v -csharp -module lassomod -o lassomod_wrap.c $<
+
+SWIG_OUTPUTS = lassomod_wrap.c SWIGTYPE*.cs lasso*.cs Lasso*.cs
+
+MAINTAINERCLEANFILES = $(SWIG_OUTPUTS)
+