summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDamien Laniel <dlaniel@entrouvert.com>2008-02-28 18:01:43 +0000
committerDamien Laniel <dlaniel@entrouvert.com>2008-02-28 18:01:43 +0000
commitc9ae4db6ccabc3cc53baf742bec2ae9a5a344390 (patch)
tree508f4702160a99fd0beb09375dcc77f3ccb61c53 /configure.ac
parent10d55df6265a7e3f61f4e92a8bf27db4477858bb (diff)
downloadlasso-c9ae4db6ccabc3cc53baf742bec2ae9a5a344390.tar.gz
lasso-c9ae4db6ccabc3cc53baf742bec2ae9a5a344390.tar.xz
lasso-c9ae4db6ccabc3cc53baf742bec2ae9a5a344390.zip
fixed php version checks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 09e8a48f..09d31a7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,7 +412,7 @@ if test x$have_expat_lib = xno; then
fi
AC_MSG_CHECKING(for PHP 4 development files)
-if $PHP4_CONFIG --version | grep -q 4 || test "x$ENABLE_PHP4_FORCE" == "xyes"
+if $PHP4_CONFIG --version | grep -q "^4" || test "x$ENABLE_PHP4_FORCE" == "xyes"
then
PHP4_VERSION=`$PHP4_CONFIG --version 2> /dev/null`
languages_available="$languages_available php4($PHP4_VERSION)"
@@ -485,7 +485,7 @@ if test x$have_expat_lib = xno; then
fi
AC_MSG_CHECKING(for PHP 5 development files)
-if $PHP5_CONFIG --version | grep -q 5 || test "x$ENABLE_PHP5_FORCE" == "xyes"
+if $PHP5_CONFIG --version | grep -q "^5" || test "x$ENABLE_PHP5_FORCE" == "xyes"
then
PHP5_VERSION=`$PHP5_CONFIG --version 2> /dev/null`
languages_available="$languages_available php5($PHP5_VERSION)"