summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2005-09-12 09:50:23 +0000
committerFrederic Peters <fpeters@entrouvert.com>2005-09-12 09:50:23 +0000
commitaeffdf5d4e9fe79fca5c512e468de1b24a8c984c (patch)
tree1d9a91b2863240bfd13846bc317b17a8b4337c49 /configure.ac
parentc4b87247c1388dfff4026b9971e185f1fb731c88 (diff)
downloadlasso-aeffdf5d4e9fe79fca5c512e468de1b24a8c984c.tar.gz
lasso-aeffdf5d4e9fe79fca5c512e468de1b24a8c984c.tar.xz
lasso-aeffdf5d4e9fe79fca5c512e468de1b24a8c984c.zip
disabled c# support for the time being
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 5 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index cefb75bf..cf16bf09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -444,11 +444,11 @@ AC_SUBST(PHP_VERSION)
# C# binding
# ----------
-AC_ARG_ENABLE(csharp, [ --disable-csharp disable the C Sharp binding],,
- enable_csharp="yes")
+#AC_ARG_ENABLE(csharp, [ --disable-csharp disable the C Sharp binding],,
+# enable_csharp="yes")
-AC_ARG_WITH(cil-interpreter, [ --with-cil-interpreter=path set location of CIL interpreter for CSharp],[CSHARPBIN="$withval"], [CSHARPBIN=])
-AC_ARG_WITH(csharp-compiler, [ --with-csharp-compiler=path set location of CSharp compiler],[CSHARPCOMPILERBIN="$withval"], [CSHARPCOMPILERBIN=])
+#AC_ARG_WITH(cil-interpreter, [ --with-cil-interpreter=path set location of CIL interpreter for CSharp],[CSHARPBIN="$withval"], [CSHARPBIN=])
+#AC_ARG_WITH(csharp-compiler, [ --with-csharp-compiler=path set location of CSharp compiler],[CSHARPCOMPILERBIN="$withval"], [CSHARPCOMPILERBIN=])
if test -z "$CSHARPCOMPILERBIN" ; then
case $host in
@@ -463,7 +463,7 @@ fi
CSHARPPATHSEPARATOR="/"
CSHARPCYGPATH_W=echo
if test -z "$CSHARPBIN" ; then
- languages_available="$languages_available C#($CSHARPCOMPILER)"
+ #languages_available="$languages_available C#($CSHARPCOMPILER)"
CSHARPCILINTERPRETER=""
if test "cscc" = "$CSHARPCOMPILER" ; then
AC_CHECK_PROGS(CSHARPCILINTERPRETER, ilrun)
@@ -771,8 +771,6 @@ dnl ==========================================================================
AC_CONFIG_FILES([lasso-src-config], [chmod +x lasso-src-config])
AC_OUTPUT(
[Makefile
-csharp/Makefile
-csharp/lasso-sharp.pc
docs/Makefile
docs/lasso-book/Makefile
docs/lasso-book/figures/Makefile
@@ -831,7 +829,6 @@ Optionals builds
Available languages: ${languages_available}
-C# binding: ${enable_csharp}
Java binding: ${enable_java}
Perl binding: ${enable_perl}
PHP binding: ${enable_php}