summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRomain Chantereay <rchantereau@entrouvert.com>2004-07-19 13:23:53 +0000
committerRomain Chantereay <rchantereau@entrouvert.com>2004-07-19 13:23:53 +0000
commit7125684426216a4195408e2d2884d8a1c28ea726 (patch)
tree0c9a100d3932d50965f7e4a2ffa3b3577457eb89 /configure.ac
parented75cd8f7f58a20d09f2e6b2c0f05f2f2f3abd93 (diff)
downloadlasso-7125684426216a4195408e2d2884d8a1c28ea726.tar.gz
lasso-7125684426216a4195408e2d2884d8a1c28ea726.tar.xz
lasso-7125684426216a4195408e2d2884d8a1c28ea726.zip
Additional test for disabling openssl detection under Windows/Cygwin
environment.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 48c48de3..08714648 100644
--- a/configure.ac
+++ b/configure.ac
@@ -347,19 +347,21 @@ if test "z$XMLSEC1_FOUND" = "zno" ; then
fi
fi
-dnl find xmlsec crypto library (openssl)
-if test "z$XMLSEC1_FOUND" = "zyes" ; then
- AC_MSG_CHECKING(for xmlsec1 OpenSSL crypto library)
- XMLSEC1_DEFAULT_CRYPTO_LIB=`$XMLSEC1_CONFIG --crypto`
- if test "$XMLSEC1_DEFAULT_CRYPTO_LIB" = "openssl" ; then
- prefix=`$XMLSEC1_CONFIG --prefix`
- if test -e $prefix/lib/libxmlsec1-openssl.so ; then
- AC_MSG_RESULT(yes)
+dnl find xmlsec crypto library (openssl) if not under Windows(c)
+if test "z$CWINDOWS" = "zno" ; then
+ if test "z$XMLSEC1_FOUND" = "zyes" ; then
+ AC_MSG_CHECKING(for xmlsec1 OpenSSL crypto library)
+ XMLSEC1_DEFAULT_CRYPTO_LIB=`$XMLSEC1_CONFIG --crypto`
+ if test "$XMLSEC1_DEFAULT_CRYPTO_LIB" = "openssl" ; then
+ prefix=`$XMLSEC1_CONFIG --prefix`
+ if test -e $prefix/lib/libxmlsec1-openssl.so ; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_ERROR(Could not find xmlsec1 OpenSSL crypto library)
+ fi
else
- AC_MSG_ERROR(Could not find xmlsec1 OpenSSL crypto library)
+ AC_MSG_ERROR(Bad default crypto library ($XMLSEC1_DEFAULT_CRYPTO_LIB) detected, must be OpenSSL)
fi
- else
- AC_MSG_ERROR(Bad default crypto library ($XMLSEC1_DEFAULT_CRYPTO_LIB) detected, must be OpenSSL)
fi
fi