summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2005-05-25 12:42:30 +0000
committerFrederic Peters <fpeters@entrouvert.com>2005-05-25 12:42:30 +0000
commit4459d446b4a5bf9f6226143db6dee1159ec5f0b1 (patch)
tree5310aa108331e4cd3f53353d91766de7865e2e0d /configure.ac
parent8195a7b31e3a0689d3ee30f4eb4e66157aa7fb27 (diff)
downloadlasso-4459d446b4a5bf9f6226143db6dee1159ec5f0b1.tar.gz
lasso-4459d446b4a5bf9f6226143db6dee1159ec5f0b1.tar.xz
lasso-4459d446b4a5bf9f6226143db6dee1159ec5f0b1.zip
preparing for 0.6.2; removes swig files if moving from non-wsf to wsf or
otherwise.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 23 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index aa3a2f50..cefb75bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@ dnl - Second number is the number of supported API versions where API version >
dnl first number.
dnl - Third number is the current API version implementation version number.
dnl See libtool explanations about current, age and release, later in this file.
-AC_INIT([Liberty Alliance Single Sign On], 0.6.1, lasso-devel@lists.labs.libre-entreprise.org)
+AC_INIT([Liberty Alliance Single Sign On], 0.6.2, lasso-devel@lists.labs.libre-entreprise.org)
dnl Check if autoconf ver > 2.53
AC_PREREQ(2.53)
dnl Check existence of a relative pathed source file.
@@ -24,7 +24,7 @@ dnl Copy stamp REVISIO-INFO in the configure script.
AC_REVISION($Revision$)
dnl Run many macros mostly needed by configure.ac.
-AM_INIT_AUTOMAKE(lasso, 0.6.1)
+AM_INIT_AUTOMAKE(lasso, 0.6.2)
dnl Create rules to automaticaly regenerate the config header.
AM_CONFIG_HEADER(lasso/lasso_config.h)
dnl Add --enable-maintainer-mode option to configure.
@@ -176,7 +176,7 @@ dnl - interfaces removed -> AGE = 0
# m = a
# r = r
current=`expr $VERSION_MAJOR + $VERSION_MINOR`
-LASSO_VERSION_INFO="4:1:1"
+LASSO_VERSION_INFO="5:0:2"
AC_SUBST(LASSO_VERSION_INFO)
dnl Compute the minimal supported ABI version for Win32 scripts and resources files.
@@ -595,9 +595,28 @@ LASSO_WSF_SUPPORT=0
if test "x$enable_wsf" = "xyes"; then
AC_DEFINE(LASSO_WSF_ENABLED, [], [Define if ID-WSF support is enabled])
LASSO_WSF_SUPPORT=1
+ if grep -q 'WSF_SUPPORT.*0' $srcdir/*/lasso_wrap.c;
+ then
+ if test "x$SWIG" = "xecho"; then
+ AC_MSG_WARN(Bindings were pre-generated without ID-WSF support)
+ AC_MSG_ERROR(and you don't have SWIG to regenerate their files)
+ fi
+ echo "removing pre-generated language interface files"
+ rm -f $srcdir/*/lasso_wrap.c $srcdir/csharp/liblassosharpglue_wrap.c
+ fi
+else
+ if grep -q 'WSF_SUPPORT.*1' $srcdir/*/lasso_wrap.c;
+ then
+ if test "x$SWIG" = "xecho"; then
+ AC_MSG_WARN(Bindings were pre-generated with ID-WSF support)
+ AC_MSG_ERROR(and you don't have SWIG to regenerate their files)
+ fi
+ echo "removing pre-generated language interface files"
+ rm -f $srcdir/*/lasso_wrap.c $srcdir/csharp/liblassosharpglue_wrap.c
+ fi
fi
AC_SUBST(LASSO_WSF_SUPPORT)
-AM_CONDITIONAL([WSF_ENABLED], [test "x$enable_wsf" = "xyes"])
+
dnl ==========================================================================
dnl User specific option.