summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrederic Peters <fpeters@entrouvert.com>2005-01-12 13:33:06 +0000
committerFrederic Peters <fpeters@entrouvert.com>2005-01-12 13:33:06 +0000
commit3d15ac68fac09ac3e266bed94e87070862949574 (patch)
tree9dc7038f0a8f0d8f196a2ecebddf04fc62b089e5 /configure.ac
parenta9847935e7beea2cfe0f95c55a3d28528a44958b (diff)
downloadlasso-3d15ac68fac09ac3e266bed94e87070862949574.tar.gz
lasso-3d15ac68fac09ac3e266bed94e87070862949574.tar.xz
lasso-3d15ac68fac09ac3e266bed94e87070862949574.zip
don't use am_path_check since it fails when check is not available (while it
should continue and disable the test suite)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 749c71d0..45c359bf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -352,7 +352,7 @@ dnl Check if php is explicitly disabled.
AC_ARG_ENABLE(php, [ --disable-php disable the PHP binding],,
enable_php="yes")
-AC_ARG_ENABLE(php-force, [ --enable-php-force force enable of the PHP binding],
+AC_ARG_ENABLE(php-force, [ --enable-php-force always enable of the PHP binding (win32)],
[ENABLE_PHP_FORCE="yes"],
[ENABLE_PHP_FORCE="no"])
@@ -521,7 +521,7 @@ fi
AC_SUBST(PERLINSTALLSITEARCH)
AC_SUBST(PERLMAN3DIR)
-AC_MSG_CHECKING(Enable Perl API)
+AC_MSG_CHECKING(for Perl API)
if test "X$enable_perl" != "Xno" ; then
if test "X$enable_perl" != "Xyes"; then
PERL=$enable_perl
@@ -548,7 +548,7 @@ dnl Check if user disabled the tests.
AC_ARG_ENABLE(tests, [ --disable-tests disable the test suite],,
enable_tests="yes")
if test "x$enable_tests" = xyes ; then
- AM_PATH_CHECK
+ AC_CHECK_LIB(check, srunner_set_log, enable_tests="yes", enable_tests="no")
AC_CHECK_LIB(check, srunner_set_xml, [AC_DEFINE(CHECK_IS_XML, [], [Define if check available with XML support])])
fi