summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRomain Chantereay <rchantereau@entrouvert.com>2004-08-03 17:03:18 +0000
committerRomain Chantereay <rchantereau@entrouvert.com>2004-08-03 17:03:18 +0000
commit169f65d306c3b6726f000ec85d352cb411bddb01 (patch)
tree310596a4fdcdbd9ac85b32c0e7eee9aa6233a955 /configure.ac
parent89681c3cb4be0d85c6599c43afef8f7d76e9d651 (diff)
downloadlasso-169f65d306c3b6726f000ec85d352cb411bddb01.tar.gz
lasso-169f65d306c3b6726f000ec85d352cb411bddb01.tar.xz
lasso-169f65d306c3b6726f000ec85d352cb411bddb01.zip
- No more need of version.h.
- Better libtool version computation.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 376aa954..3bd70710 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,7 +123,8 @@ AC_DEFINE_UNQUOTED(LASSO_WINDOWS_VERSION, $windows_version, [Windows version of
# then set AGE to 0.
#
# syntax: CURRENT[:REVISION[:AGE]]
-LASSO_VERSION_INFO="$VERSION_MAJOR:$VERSION_MINOR:$VERSION_RELEASE"
+current=`expr $VERSION_MAJOR + $VERSION_MINOR`
+LASSO_VERSION_INFO="$current:$VERSION_RELEASE:$VERSION_MINOR"
AC_SUBST(LASSO_VERSION_INFO)
AC_MSG_RESULT([Setup version.])